U-blox SARA-R410M freezes

Hi,
I’m experiencing a problem with a SARA AFF equipped with u-blox SARA-R410M modem - firmware 02B-01 : few seconds after startup, the modem freezes and does’not respond to any command - even a simple AT.
I devoloped my software on a card equipped with SARA-R10M , firmware 02B-00, and it worked perfectly.
I did’nt find any workaround except a blog stating that this problem could be solved with a modem firmware upgrade.
Is it corract ? and, please, could you give me assistance on the issue ? Where do I get the firmware and which procedures to apply?

Kind regards
Alessandro

Hi @alelig,

Please send an email to info at sodaq dot com and ask for the firmware files.

Best regards,
Jan

There is a power saving setting which disables the UART after 6 seconds of inactivity. The modem can them be woken up by further UART activity.

The setting is AT+UPSV which can be disabled with “AT+UPSV=0”.
Also you might want to disable PSM using “AT+CPSMS=0”.

It is possible that some of the default settings are different with a new version of the modem firmware.