Trouble with SARA N211 firmware update


Today I asked for and retrieved firmware updates by mail from SODAQ (thanks for that). However, UEUpdater failed to update the firmware of my SARA N211 NB-IoT Shield (with crowduino).

Because the ATI9 command did not work for me, I first tried updating to version A07. But, this failed. Now my AT commands are not working anymore and if I retry to update the firmware, UEUpdater gives the following feedback for a few seconds:

“Waiting for UE to reboot to establish communication”
“Update in progress (reset UE if no response after 10 seconds)…”

Then, it fails with this message:

“Failed: Timed out trying to establish connection”

Before I tried updating the firmware, I had version V100R100C10B656 (Retrieved by executing AT+CGMR).

I already searched through the forum to see if I could fix the problem. I found these posts:

However, these solutions did not work for me. I also see posts about resetting the User Equipment, but I don’t know how I can do this.

Does someone know what I can do to fix my problem?

Thanks for the help,

I found another post that is very detailed in how to update the firmware with a USB to Serial converter:

So I bought a converter, but while I wait until it arrives I have a some questions about this update method:

  1. In the post is mentioned that different versions of CodeLoader are needed for different firmware versions. I read in the User Guide of UEUpdater that it replaces CodeLoader. Can I expect that this method of updating the firmware also works with UEUpdater?

  2. In the post it says “connect the RX, TX and the GND of the USB-to-Serial converter to the top of the shield (RX=D0, TX=D1)”. I want to make sure I’ll use the right ports, as I see multiple GNDs. So, are these ports I need to use?


I managed to do the firmware upgrade. After some struggling I found out how to reset the UE and use the USB to Serial converter to upgrade the firmware.

These two post gave me the solution:

1 Like

@niekvn1 Thanks for sharing your solution!