Tracker - the finer points

I recently bough a Cow Tracker … for a project to track wild horse in Namibia. With a little recent experience in TTN and LoraWAN, I have got it conneted to TTN and displaying a position in Node Red.

However it is not clear to me from the instructions

https://learn.sodaq.com/Boards/One/Examples/Tracker/

how I put the following comments in

  • Turn off ADR: adr=0
  • Set Spreadingsfactor 7, 8 or 9: sf=9

or, say, enable Cayenne

Enable the cayenne low power payload by sending cay=1 in the bootmenu of your device.

Therre must be some place in the code to be compiled (as there is for the AppEUI’s) to set these parameters.

In particular, I am concern about the drop in battery voltate over three days…while in the South of England Sun… and may not have some low-power setting enabled

Advice much appreciated

Richard Wylde

image

If you scroll down on the page you linked, refer to the section under ONE v3 titled Universal Tracker - SODAQ payload and Cayenne LPP, Configure Your Board.

You will need to connect to your board with a Serial Monitor. The three parameters you mentioned (ADR, SF and Cayenne) are set by command. Once set, save the configuration and allow the tracker to exit the config mode.

I’m surprised you were able to get your board connected at all as this is the same process used to enter the DevEUI, AppEUI and AppKey.

Thansk for this. I will have another go at the terminal screen, but it did not look editable when I looked at it…

Hence setting the TTN parameters in the top page of the sketch.

image

In passing, can these other parameters be set this way… It seem a more secure method?

Any comment on the dropping value of the battery voltage? What setting are need to conserve power?

Advice appreciated

Richard

I have now reactived the Tracker and appera to have set the spreading factor to 9 and turned ADR off

however the gateway is still showing the data rate as SF7

image

What am I doing wrong?

Help appreciated

Richard

There might be a number a few things happening here which could result in another SF being used. Primarily, either the device is not being configured for the correct SF or ADR is not being disabled, or somehow those settings are being overridden on the MAC layer.

To start with I would recommend enabling full debug for the RN2483 library and capturing all the raw commands and response sent during the configuration. Using that it will be possible to confirm that at least the configuration is being done correctly.

In order to enable debug, you need to make sure the ‘#define DEBUG’ in the cpp file is not commented out. Additionally, the instance needs to be assigned a debug / diagnostic stream.

Gabriel

Thansk for this. Have set the “#define DEBUG” and recompiled.

Setting the satelite to 6 gave me 7 satellites, rather than 4.

Not sure I undertand your comment

Additionally, the instance needs to be assigned a debug / diagnostic stream.

but there is (as one might expect) now change in the SF7

image

I have a particular interest in the SF as the plan is to use this to track wild horse in Namibia, and range is therefore important… and at the same time the Gateway is not likely to be overloaded.

Help appreciated

Richard

Just a quick additional comments… other changed paameters - such at the “fi” are being stored…

Is there somewhere in the code (I fear I can’t see it) where the inital “ADR” and “SF” parameters are set.

Richard

Hi @cavediver,

Default setting values can be found in the config.cpp file.
Some default settings are overwritten in the .ino file.

Best regards,
Jan

Jan

Thanks for this…Mea Culpa . I should have seen it.

(remembering I am serching for long range, and can cut down the GPS frequency if battery consumption turns out to be poor)

I have set sf=11 there, adr =0 etc…and it appears correctly on the boot terminal screen.

However TTN is still showing “data_rate”: “SF7BW125”,

Is this an error on the part of TTN (coming from, say the first contact)… or is the sf=11/adr being overruled?

Can I check this by looking at the actual S/N or rssi values?

Best Wishes

Richard

I performed some tests by setting the sf to different numbers (7,9,12) and there is no change in the rssi number/snr… from which I conclude that - notwithstanding what the ternal says, the SODAQ ONE is not changng the sf parameter.

Advice appreciated please

Richard Wylde

From the comment

Some default settings are overwritten in the .ino file.

I found a setting in “LoRaHelper” which I also changed… to sf=11, as below

but still no luck.

are there other commands lurking about somewhere?

Help appreciated

Richard

Hi @cavediver,

We have different versions of the Universal Tracker, which one are you using?
https://support.sodaq.com/Boards/One/Examples/Tracker/

Best regards,
Jan

It is this version

Is it the case that the unit will not go beyond sf=9… ie trying to work at sf=11 etc will fail too?

Though I am lost as to why increase the time to transmit a fixed number of bytes should mean that “a payload” should not fit.

and - if sf=9 is the maximum sf value, are ther parameters lurking elsewhere in the code?

Advice/Help appreciated

Richard

Hi @cavediver,

Thanks for sharing the version of the Universal Tracker you use.

I can see in your order you bought a EU version RN2483.
Here you can use all spreadingfactors. 7, 8, 9, 10, 11 and 12.

There is a known bug in the v1.0.3
In the systemSleep() you should remove “network.setActive(false);”

I recommend to not change anything in the LoRaHelper.
Keep the changes to the config.cpp and the .ino
You should be able to check in the menu the current/used settings.

I don’t see anything in the code what could cause an issue.
Can you turn on debug, dbg=1 in the menu.
And share the logfile. You can email it to me jan at sodaq dot com.

Best regards,
Jan

Thanks… will try that when a second cow tracker arrived

I fear - during tests in some woodland I own - the first on has been taken/stolen… I am ever hopeful it might pop up somewhere…

Richard

The replacement Cow tracker has arrive, and is now gving my required sf=12… Thank you

In passing, if this is a know bug… will you be correcting the files on the net?

Richard

image