SODAQ SARA N11 unable to attached to network

Hello,

I got problem connecting to TDC network using NB-IoT board: SODAQ SARA N211

I start with nbIOT_serial_passthrough and AT commands please tell me if I am using wrong parameters:

ATI9
06.57,A07.03

//restart:
AT+CFUN=0
AT+CFUN=1

+CEREG: 0,“0000”,“0”,7,

OK

//Connect to TDC

AT+COPS=1,2,“23801”

+CEREG: 2,“0000”,“0”,7,

+CSCON: 1

//use TCD band for NB-IoT
AT+NBAND=20

OK

//check signal strength:
AT+CSQ

+CSQ: 14,99

//Wait for attach, 1 = attached.

AT+CGATT?

+CGATT: 0

OK

It seems that I am not attached.

Could you tell me if I am missing something?

Hi Tomb,

The configuration looks OK, you’re sure the SIM card works fine?
You may want to try M-Center.


You’ll need the AT passthrough for that (as you have now).

Regards,
Thom

I tried to use m-center. Unfortunately, the entered AT commands do not give an answer.
AT commands work in the Arduino IDE. Commands work in Tera Term.
I have made the same connection settings in M-center as in Tera Term.
Port: COM3
Baud rate: 9600
Flow control: none
Date bits: 8
Stop bits: 1
Parity: none
I clicked “Connect”. I opened “AT terminal”, entered AT commands and there is no reply. I do not know why.

Hi @tomb

The reason you cannot connect is the firmware.
Please send a message to info at sodaq dot com to request new firmware for your module.
And follow the instructions on this page:
https://support.sodaq.com/Boards/Sara_AFF/#n2

Best regards,
Jan

I have uploaded the new firmware, version A10. Unfortunately, M-center still gives no response in the AT terminal. What could be the problem?
But the command in tera term:
AT + CGATT?
already gives the answer:

  • CGATT: 1

Hi @tomb,

Super that you have updated your module to version A10.
This is required to make a proper connection to the networks.

I just tested with a u-blox module and the passthrough sketch on the support pages with m-center. I didn’t have any issues.

I just noticed you used this sketch, it should work but please do NOT use the Sodaq_nbIOT library. We stopped development. We continued to make a library for each module. The Sodaq_N2X is the new library.

Can you try with this sketch, I also tested with this sketch.
https://support.sodaq.com/Boards/Sara_AFF/Examples/passthrough/

I used m-center v.02.02.00
If you have an older version, please update to this one so we use the same. Easier for debugging.

Can you share the settings you have used in m-center?

Best regards,
Jan

Hi
I used m-center v.02.02.00.

Now I tried with this sketch:
https://support.sodaq.com/Boards/Sara_AFF/Examples/passthrough/
No change.

Port settings:
Port: COM3
Baud rate: 9600
Flow control: none
Date bits: 8
Stop bits: 1
Parity: none

Trace default protocol: none
Trace AT commands: I tried ON and OFF.
Disable COM port lines (I also tried ‘Enable’)

Printscreen:

Hi Tomb,

Incredibly strange to see m-center not working with your serial port. Something must be blocking m-center from working properly.

That aside, perhaps you don’t need it. Could you try running your old passthrough commands manually?
We also advise you to use our library my colleague just mentioned, that should take care of the initialization.

Regards,
Thom

Hi Thom.
Do you have any more information why the A7 firmware are not working any more? We have the same problem with our units that has been working fine for 1,5 years until about two weeks ago. They have fw A7 and if we update them to A10 they now works fine.