Sodaq One Setup fail

Hi,

After loading the tracker sketch (http://support.sodaq.com/sodaq-one/connect-to-the-things-network/) I finally got rid of the “OTAA setup failed!” reply on the serial monitor and succesfully made a connection to TTN. Now I am struggling with the One board constantly resetting all the keys that I had set with the tracker, after I unplug the usb. Do I need to re-run the tracker sketch and re-enter all keys every time I unplug the usb power?

More generally I was wondering why I need to use this tracker sketch and why I cant skip the tracker for setting keys. Couldnt I just put my keys in the basic sketch from http://support.sodaq.com/sodaq-one/loraone-lora-basic-sketch/ and make it work? Right now I need to rerun the Tracker sketch-> input my keys in it -> wait 30seconds -> upload the basic sketch with my keys -> Can finally do my work. If I dont do this after everytime I unplug the power, the LoRa one just gives me the “OTAA setup failed” response.

Hi,

Are you close enough to the gateway to get a succesful OTAA?
When you try to do to many OTAA’s you will not get new keys due to the dutycycle, in this case you will get “join denied”

Hi,

Thanks for the reply. The gateway is located an arm-length away within line of sight. I tried to OTAA all day long but the same problem persists, unless I re-upload the tracker sketch and put in my keys with commands, then it works. Besides, the only error message I get is “OTAA setup failed!” “There was no response from the device” after it resets my keys.

This happens after I unplug the power. It just forgets the keys and I can’t put the keys back in with the basic sketch. I need to use the tracker sketch to put in the keys, after which I can upload the basic sketch. Otherwise it doesn’t work.

Bump. Can someone tell me how to input the keys, the basic sketch leaves me with “OTAA setup failed!”.

@Fritz

Do you reset the module before you try to set the new keys?

//Hardreset the RN module
pinMode(LORA_RESET, OUTPUT);
digitalWrite(LORA_RESET, HIGH);
delay(100);
digitalWrite(LORA_RESET, LOW);
delay(100);
digitalWrite(LORA_RESET, HIGH);
delay(1000);

Thanks for the reply.

I noticed I am having the same issue as this thread [Problem] Connecting SODAQ One with LoRa-shield to LoRaWAN. Can you maybe post what was the problem there? Resetting the RN module didn’t fix it.

@Fritz
What version number and revision numbers are on the pcb?

I see a lot of numbers so ill just list them all (I have no idea what the version number is):

FF-MJZ 1624
87522
SODAQ ONE REV 4

Microchip RN2483 1621YHQ

I couldn’t find any numbers on the shield-like board I plug the Sodaq on.

This explains why this

is not working. The reset pin is not implemented in rev4. From V2 and up the pin is implemented.

Can you test if the problems are fixed when you programm your device.
Disconnect it 5 seconds from your powersource and boot it up again.
Then open the com port when it’s available and see if it succesfully connects to your network.

Kind regards,
Jan

I tried this 2-3 times but it didn’t work. It still gives me the OTAA setup failed and There was no response from the device.

I cant replicate the issue with my rev4 and this sketch.

If you use ABP do you all the time get a succesfull transmit?

No With ABP I also get ABP connection failed, cannot communicate with LoRaBEE device.

As I said: After loading the tracker sketch (http://support.sodaq.com/sodaq-one/connect-to-the-things-network/) I finally got rid of the “OTAA setup failed!” reply on the serial monitor and succesfully made a connection to TTN.

With this tracker sketch I need to manually input the keys and then everything works. After this tracker sketch I can upload my own basic sketch and the basic sketch will also work. But (here is where it gets weird) when I re-upload the basic sketch everything stops working and I get errors.

To sum it all up:
The basic sketch won’t work till I’ve manually input the keys with the tracker sketch first. I need to do this step every time. Same for ABP method.

Update for everyone stuck with the same problem, use LoRa Serial Passthrough sketch provided here: http://support.sodaq.com/sodaq-one/loraone-lora-basic-sketch/

This solved my problem. The sodaq_rn2483 library does not work with my sodaq one v1 rev4.

cheers

I’ve had the same problem too. I can get my SodaqOne Rev4 to connect to TTN using TheThingsNetwork.h and CayenneLPP.h with no Sodaq_RN2483.h library in the code. But when I run the Tracker code with the RN2483 library the Lora connect fails. Is there another version of the RN2483 library available that works with Rev4? Or some help to get the code running without the library? Thanks in advance.

Hi awootton,

As far as I know theres still no working library available for this problem. All you can do is basically use the LoRa Serial Passthrough sketch provided here: http://support.sodaq.com/sodaq-one/loraone-lora-basic-sketch/10

It should not be that much more of an issue. You can do everything even without the RN2483 library.

cheers

Thanks Fritz, I tried running the Tracker software without the RN2483 library but it started to throw errors due to calling functions in the library. Given that Tracker is large and complex, I wasn’t really game to start attempting to debug.
Not to worry as I was really just trying to map the connectivity in my city (Melbourne) and I’ve had some success with TTNMapper. As far as the SodaqOne is concerned I’ve certainly been able to get GPS fixes and send them up to TTN.