Sodaq ONE and myDevices Cayenne

Within the myDevices Cayenne dashboard i can add the sodaq one through
add device->loRA(Beta)->The things network->Lora ONE

When i add an ABP Sodaq ONE device through the Device EUI the following error appears:

Please fix the following errors:
Error: conflict

Any ideas? It seems there is a conflict with the deveui but i have removed all devices from my projects.

Seems the Cayenne Device EUI removal sometimes lacks behind and you need to inform the technicians on myDevices side. Works now.

Next step is to get proper data using LPP…

Ow even better! The Sodaq tracker has been updated to reflect the Cayenne LPP payload!

Kudos to Sodaq!

1 Like

Well, the update is only for the Sovaq One v2. isn’t it? I have an older Sodaq One from Kickstarter and could not see support for Cayenne in the Universal Tracker software for that version… Are there any plans to provide an update?

Here is a version of the Sodaq V1 with Cayenne LPP

Jan, thanks a lot for the hint. Finally it was not that difficult to update the C code…

Hi, finally I get my desired TTN Gateway.
So I have tried to get my sodaq one V1 revision 4 working with it.

To get working first I have to get last beta firmware v1.03 for the ttn Gateway, I see then my ttn uno working and communicates with it.
Then for the sodaq one I take the SodaqOne-UniversalTracker V1 with Cayenne integration, but I need to update the Sodaq_RN2483 files with the one without Cayenne (the github seems not to be uptodate for this files).
I have also change the payload fonction with the version in SodaqOne-UniversalTracker V2 to get correct Temperature and voltage output in myDevices.

Last thing, after uploading a new sketch and reset the app and key value : I need to power off my ttn Gateway. waiting for at least 15 minutes before starting it. Then when it is connected to ttn network I restart the sodaq one and then the lora initialisation is OK. If I restarted the Sodaq without the ttn gateway the Lora init failed with denied value !

Last thing to do is to have a gps fix outside now :wink:

Ok got only one fix, but after always Lora init failed with denied value.

I have upgraded Lora firmware to 1.03, I will see tomorrow if it will be up again, Strange …

Hello, guys
i am having the same issue.
With a determined deveui, i get this message
Please fix the following errors: Conflict
when trying to add again

The device was in service in cayenne, but delelted recently.

Tell me, how i can contact technicians or generate a ticket to cayenne?

Thanks in advance.


Just post a question on the mydevices community: