SARA-R410M doesn't attach to networks (NB-IoT)

Hi,

I’m currently trying to get my R410M to work. I’m in Germany and I have a Vodafone and a 1nce (Telekom) SIM, both of which work with my SARA-N211.
Here’s what I’m trying to do (With the 1nce-SIM, but it’s the same with Vodafone):

at+ubandmask=1,128 (both networks use band 8 for NB-IoT)

at+urat?
+URAT: 8

at+cgdcont?
+CGDCONT: 1,"IP","iot.1nce.net","0.0.0.0",0,0,0,0

at+cops=?
+cops: (1,"262 01","262 01","26201",9),,(0,1,2,3,4),(0,1,2)

at+csq
+CSQ: 8,99

at+creg=2
at+cereg=2
at+creg?
+CREG: 2,2
at+cereg?
+CEREG: 2,2

That status doesn’t change and it doesn’t matter if I only use creg or cereg or both.

at+cops=1,2,"26201"

Sometimes it doesn’t respond at all, but when it does, it takes a couple minutes and the response is:
+CME ERROR: no network service
I also tried that with different combinations of CREG and CEREG, but that doesn’t matter either.

at+cgatt=1
+CME ERROR: no network service

at+cgatt?
+CGATT: 0

I’m currently all out of ideas. It would be amazing if someone could help me.

As far as I know, both networks need AUTOCONNECT to be set to FALSE and CR_0354_0338_SCRAMBLING set to TRUE and the R410M has both set to TRUE by default, but I couldn’t find any way to change these settings.

I’m using a 1nce SIM too.

From my tests I can get it to work only with AT+URAT=7,8.
I forked and modified the Sodaq_nbIOT to do that. Replace the URAT setup with println("AT+URAT=7,8"); in the Sodaq_nbIOT::setR4XXToNarrowband of the Sodaq_nbIOT.cpp file.
That should do the trick.

Here is an example session:

>> AT
[rdResp]: timed out
>> AT
[rdResp]: timed out
>> AT
[rdResp]: timed out
>> AT
[rdResp]: timed out
>> AT
[rdResp]: AT
[rdResp]: OK
[rdResp]: timed out
>> AT+CMEE=2
[rdResp]: AT+CMEE=2
[rdResp]: OK
>> ATE0
[rdResp]: ATE0
[rdResp]: OK
>> AT+URAT=7,8
[rdResp]: OK
>> AT+UDCONF=1,1
[rdResp]: OK
>> AT+CPIN?
[rdResp]: +CPIN: READY
[rdResp]: OK
>> AT+URAT?
[rdResp]: +URAT: 7,8
[rdResp]: OK
>> AT+CFUN=0
[rdResp]: OK
>> AT+CNMI=0
[rdResp]: OK
>> AT+CGDCONT=1,"IP","iot.1nce.net"
[rdResp]: OK
>> AT+CFUN=1
[rdResp]: OK
>> AT+CSQ
[rdResp]: +CSQ: 99,99
[rdResp]: OK
>> AT+CSQ
[rdResp]: +CSQ: 99,99
[rdResp]: OK
>> AT+CSQ
[rdResp]: +CSQ: 99,99
[rdResp]: OK
>> AT+CSQ
[rdResp]: +CSQ: 99,99
[rdResp]: OK
>> AT+CSQ
[rdResp]: +CSQ: 29,99
[rdResp]: OK
>> AT+CGATT?
[rdResp]: +CGATT: 1
[rdResp]: OK
>> AT+CGPADDR
[rdResp]: +CGPADDR: 1,xxx.xx.xxx.x
[rdResp]: OK
1 Like

Hi @username1,

The trick to connect in to the 1NCE sims is to leave the operator selection on automatic.
AT+COPS=0

I see no cops command in @Alexandre his output. The default of the module is automatic.

The enables LTE-M and NB-IoT.

Best regards,
Jan

1 Like

Hi @Jan

Yes, mine is set to automatic operator selection.

Still, if I use the same session but set the network to NB-IoT only (AT+URAT=8), I can’t connect and AT+CREG return registration denied.
I’m in Switzerland and there is currently no LTE-M network that I’m aware of. Still, setting AT+URAT=7,8 fix my connection issue.

I agree that it doesn’t make sense :slight_smile:

Edit: Fixed typo in the first AT+URAT command.

1 Like

Hi @Alexandre,

Thanks for sharing your workaround!

What firmware version are you using?
ATI9 will return the firmware version.

Best regards,
Jan

Thanks @Jan.

I’m using the stock firmware. That is L0.0.00.00.05.06,A.02.00.
I contacted your support last week to get an update and was redirected to someone from Adelco, I’m waiting for response.

BTW, I see there was a typo on my previous post. The frist command (that dosen’t work) should read AT+URAT=8).
I will edit it for posterity.

1 Like

@Jan @Alexandre Thank you very much for your help.

I followed your advice, replicating Alexandre’s example session (after resetting the modem, of course), but unfortunately, it wasn’t successful. Here are my results:

at+cmee=2
at+cmee=2
OK

ATE0
ATE0
OK

at+urat=7,8
OK

at+udconf=1,1
OK

at+cpin?
+CPIN: READY
OK

at+urat?
+URAT: 7,8
OK

at+cfun=0
OK

at+cnmi=0
OK

at+cgdcont=1,"IP","iot.1nce.net"
OK

at+cfun=1
OK

at+csq
+csq: 99,99
OK

at+csq
+csq: 99,99
OK

at+csq
+csq: 6,99
OK

at+cgatt?
+CGATT: 0
OK

at+cgpaddr
+CGPADDR: 1,
OK

at+cgatt?
+CGATT: 0
OK

at+cgpaddr
+CGPADDR: 1,0.0.0.0
OK

The response to the last two commands isn’t as expected.

What seems weird to me: When I trigger an operator search while the 1NCE-SIM is inserted, I get the following result:

at+cops=?
+cops: (1,"262 02","262 02","26202",9),,(0,1,2,3,4),(0,1,2)

This would suggest there’s no Telekom coverage.
However, when I trigger the search with the Vodafone-SIM inserted, the Telekom network shows up:

at+cops=?
+cops: (1,"262 01","262 01","26201",9),(1,"262 02","262 02","26202",9),,(0,1,2,3,4),(0,1,2)
1 Like

Hi,

A CSQ of 6 isn’t really strong, but you should be able to connect.

Can you start your AT sequence with AT+CFUN=15, this will reset any saved profile.
Send AT+COPS=0 to make sure you use the automatic mode.

Best regards,
Jan

Depending on the antenna placement, I can get higher CSQs, highest I’ve seen was 31. I still couldn’t connect.

I just tried that, the result is very much the same.

Hi,

It is possible to contact 1nce about the coverage?
Maybe you see the network, but nb-iot isn’t available on the cell yet.

Best regards,
Jan

Hello,

thank you for the suggestion.
I’m assuming that it must be available, because my Sara N211 works fine with 1nce.
I might still try to contact 1nce, maybe they’ll be able to help me.