SARA R410 USB - No more download


For weeks, I was using a SODAQ R410 and everything was working fine.

Since yesterday, I can’t download the files on my board : The dowloader can’t find any board on any port com.

The hardware seems to be good :

  • When I connect the board to my computer the SODAQ SARA is detected as a valid USB port.

  • With Arduino environment, when I ask for information about the board, I get coherent information

      BN: Arduino Zero (Native USB Port)
     VID: 0x2341
    PID: 0x804d
    SN: 585A2BE45050314631202020FF132330
  • When I double press the reset button I get the blue led that slowly blinks . Even in this mode, I can’t download the software.

I have the same issue on my two computers (Win 10).

I have also tested my computers with other boards (ATmega2560) and they work fine.

The issue seems to be linked to the SODAQ board.

Has anybody an idea about what i need to do ?

Many Thanks in advance

Hi @Franck,

Do you use the Windows Installer?
Using the Windows Store App caused some problems the last time I tried it.

Best regards,

Hi Jan, Hi eveybody,

Many thanks Jan for your help.

I’ve just fixed it and I found the reason !!

After many trials, I’ve been able do download a small software (Blink) by using the bootloader (double push on the reset button).

Then, step by step I’ve been able to determine what what the reason : it was due to the declaration of a too large unsigned int array in my software : When, I was accessing these data, I was probably writting in a ram area dedicated to some “system” function.

It’s really a beginner’ fault that is not easy to detect when you are stucked…
I will now be more rigourous on this point and I’m now looking on how to get a “picture” of the available ram before dowloading the software.

Best regards

1 Like

Hi Franck,

I’m not sure how to determine how much memory is statically used by a program at build time. Arduino does report how much program storage space the build uses, but not how much memory (not on the SAMD platform at least).

One thing I would recommend, if you are using large arrays of predefined data, is to declare the array(s) with the ‘const’ keyword. This will cause the arrays to only occupy program space, and stop them from being loaded into the SRAM. This of course removes the ability to make any modifications to those arrays at run-time.