SARA R410 LTE-M no network service

Hi,

We are trying to connect to the KPN LTE-M network using the following example: https://support.sodaq.com/Boards/Sara_SFF/examples/passthrough/.

KPN gave us the APN m2m.newlinemobile to use which gave the “+CME ERROR: no network service” error when using the AT command AT+CGATT=1 to attach to the network. We also tried the following APN’s (which resulted in the same error):

internet.m2m
ltem.webtrial.m2m
ltem.internet.m2m

We have tried altering the command using the information from the unblox R410 datasheet (https://www.u-blox.com/sites/default/files/SARA-R4_ATCommands_(UBX-17003787).pdf).

We also checked if the firmware was up to date. The current version is L0.0.00.00.05.08,A.02.04.
In the image provided you can see the used commands and the response.

We hope we provided you with enough information to figure out what we did wrong.

Hi @Tho.mas,

I see you set profile 1, this is auto profile selection. Maybe it doesn’t get the correct settings from the SIM.
You can try with profile 100 to set it to General Europe.

Let me know if this helps!

Best regards,
Jan

Hi Jan,

(I’m replying as @Tho.mas, because I tried uploading 2 pictures in one post and this apparently is not allowed and instantly places the account on Hold…)

Thanks for responding.

We’ve tried setting the profile to 100. This didn’t yield any results.

However, what caught our attention was the error code we got returned by the AT+CEREG command. When comparing this response to the AT commands (& responses) from the datasheet, it looks like the format is wrong.

Where we get a ‘B’ as response, the datasheet tells us that the expected value on that position should be a number. As you can see in the previous post, we got almost the same response. So, our troubleshooting has somewhat grinded to a halt.

Also, when entering the ‘AT+COPS=1,2,“20408”’ (forcing KPN) we get the response ‘+CME ERROR: no network service’, although this command was working properly before. This EVEN happened when I backtracked my own steps and executed the exact same commands as the post before.

I’m desperate to solving this issue. Can you please help me.

Thank you in advance.

I didn’t get a notification about this :cry: I did re-activate his account.
Please send a mail to support@sodaq.com if this happens again!

After changing settings, did you send the command AT+CFUN=15 to save the settings and reboot?

Best regards,
Jan

Added images for troubleshooting.

Hoi Bob,

Profile is allowed to be 100 for KPN.
Profile 1 is use settings from the SIM card, so the profile will update to another provider if listed.
Profile 100 can be used also for KPN.

Can you check at your SIM card provider that the SIM is activated for LTE-M ?
Note: LTE(4G) is not the same as LTE-M

Best regards,
Jan

Hi,

Rather than create a new post I have added my query here, as it seems very similar, and the previous poster did not seem to get a definitive answer.

I’m using a Sodaq Sara R412M board in the UK. I’ve successfully connected to NB-IoT using a Vodafone trial SIM and I’m now trying to get it to work with an O2 LTE-M trial SIM. According to the O2 LTE-M coverage maps I should get a good signal.

I’ve used the Sodaq_SARA_R4_Maker app to enter the following commands (using CMD mode).

ATE0
AT+CCID
AT+CGSN
AT+CIMI
AT+CGMR
AT+COPS=2
AT+UMNOPROF=100
AT+CFUN=15
AT+UMNOPROF?
AT+URAT=7
AT+URAT?
AT+UBANDMASK?
AT+CFUN=0
AT+CGDCONT=1,“IP”,“m2mtrial.telefonica.com
AT+CFUN=1
AT+CGDCONT?
AT+COPS=?
AT+COPS=1,2,“23410”

Here is the output I get. The failure to connect to the network at the end is consistent.

11:49:54.594 -> SODAQ SARAR4 MAKER 20190215.1
11:49:54.594 -> Booting up…
11:50:00.448 ->
11:50:15.249 -> Commands:
11:50:15.249 -> AT Command Mode (CMD):
11:50:15.249 -> GPS Dump (GPSDUMP):
11:50:15.249 -> Init network (INIT):
11:50:15.249 ->
11:50:15.249 -> Settings:
11:50:15.249 -> IMEI : 354679090188387
11:50:15.249 -> Telco (tmobile=0, vf-n=1, vf-m=2, kpn=3, mono=4) (tlc=): 0
11:50:15.249 -> Upload Interval (min) (sri=): 5
11:50:15.249 -> GPS Fix Timeout (sec) (gft=): 120
11:50:15.249 -> Minimum sat count (sat=): 6
11:50:15.249 -> APN (apn=): cdp.iot.t-mobile.nl
11:50:15.249 -> Force Operator (opr=): 20416
11:50:15.249 -> Network (LTE-M=7, NB-Iot=8, 2G=9) (rat=): 8
11:50:15.249 -> Band Mask (bnm=): 524288
11:50:15.249 -> Server URL/IP (url=): 172.27.131.100
11:50:15.249 -> Server port (prt=): 15683
11:50:15.249 -> Send ATT header (OFF=0 / ON=1) (ahd=): 0
11:50:15.249 -> All Things Talk Token (att=):
11:50:15.249 -> Payload type (0=cbor, 1=hex, 2=json) (pld=): 0
11:50:15.249 -> Temperature offset (tof=): 0
11:50:15.249 -> GPS (OFF=0 / ON=1) (gps=): 1
11:50:15.249 -> Debug (OFF=0 / ON=1) (dbg=): 1
11:50:15.249 ->
11:50:15.249 -> On-the-move Functionality
11:50:15.249 -> Acceleration% (100% = 8g) (acc=): 25
11:50:15.249 -> Acceleration Duration (acd=): 0
11:50:15.249 -> Accelerator Trigger
11:50:15.249 -> Sensitivity (1-50) (act=): 10
11:50:15.249 -> Back-off time (sec) (bot=): 10
11:50:15.249 ->
11:50:15.249 -> Enter command: cmd
11:50:20.961 ->
11:50:20.961 -> AT Command Mode
11:50:20.961 ->
11:50:20.961 -> 1 ATE0
11:50:20.961 -> 2 AT+URAT=8
11:50:20.961 -> 3 AT+CCID
11:50:20.961 -> 4 AT+CGSN
11:50:20.961 -> 5 AT+CIMI
11:50:20.961 -> 6 AT+CGMR
11:50:20.961 -> 7 AT+UBANDMASK?
11:50:20.961 -> 8 AT+UMNOPROF?
11:50:20.961 -> 9 AT+URAT?
11:50:20.961 -> 10 AT+CFUN=0
11:50:20.961 -> 11 AT+CGDCONT=1,“IP”,“cdp.iot.t-mobile.nl”
11:50:20.961 -> 12 AT+CFUN=1
11:50:20.961 -> 13 AT+CGDCONT?
11:50:20.961 -> 14 AT+COPS=1,2,“20416”
11:50:20.961 -> 15 AT+CSQ
11:50:20.961 -> 16 AT+CREG=2
11:50:20.961 -> 17 AT+CREG?
11:50:20.961 -> 18 AT+CGPADDR
11:50:20.961 -> 19 AT+UDCONF=1,0
11:50:20.961 -> 20 AT+USOCR=17
11:50:20.961 -> 21 AT+USOST=0,“172.27.131.100”,15683,4,“Data”
11:50:20.961 -> 22 AT+UDCONF=1,1
11:50:20.961 -> 23 AT+USOST=0,“172.27.131.100”,15683,4,“44617461”
11:50:20.961 -> 24 AT+USOCL=0
11:50:20.961 -> 25 AT+URAT=7
11:50:20.961 -> 26 AT+CFUN=15
11:50:20.961 ->
11:50:20.961 -> You can use one of the above numbers, or type ‘exit’ for quit AT Command Mode
11:50:20.961 ->
11:50:29.735 -> ATE0
11:50:29.735 -> >> ATE0
11:50:29.735 ->
[rdResp]: ATE0

11:50:29.770 -> [rdResp]: OK
11:50:36.187 -> AT+CCID
11:50:36.187 -> >> AT+CCID
11:50:36.187 ->
[rdResp]: +CCID: 8934072500003882366
11:50:36.220 -> [rdResp]: OK
11:50:42.293 -> AT+CGSN
11:50:42.293 -> >> AT+CGSN
11:50:42.293 ->
[rdResp]: 354679090188387
11:50:42.327 -> [rdResp]: OK
11:50:48.543 -> AT+CIMI
11:50:48.543 -> >> AT+CIMI
11:50:48.543 ->
[rdResp]: 214074303530737
11:50:48.578 -> [rdResp]: OK
11:50:54.081 -> AT+CGMR
11:50:54.081 -> >> AT+CGMR
11:50:54.081 ->
[rdResp]: M0.09.00 [Jan 31 2019 18:59:31]
11:50:54.115 -> [rdResp]: OK
11:50:59.500 -> AT+COPS=2
11:50:59.500 -> Initializing module, this may take 3 minutes…
11:50:59.500 -> >> AT+COPS=2
11:50:59.500 ->
[rdResp]: OK
11:51:04.948 -> AT+UMNOPROF=100
11:51:04.948 -> >> AT+UMNOPROF=100
11:51:04.948 ->
[rdResp]: OK
11:51:10.395 -> AT+CFUN=15
11:51:10.395 -> >> AT+CFUN=15
11:51:10.395 ->
[rdResp]: OK
11:51:15.888 -> AT+UMNOPROF?
11:51:15.888 -> >> AT+UMNOPROF?
11:51:15.888 ->
[rdResp]: AT+UMNOPROF?

11:51:15.888 -> [rdResp]: +UMNOPROF: 100
11:51:15.888 -> [rdResp]: OK
11:51:21.070 -> AT+URAT=7
11:51:21.070 -> >> AT+URAT=7
11:51:21.070 ->
[rdResp]: AT+URAT=7

11:51:21.070 -> [rdResp]: OK
11:51:26.714 -> AT+URAT?
11:51:26.714 -> >> AT+URAT?
11:51:26.714 ->
[rdResp]: AT+URAT?

11:51:26.749 -> [rdResp]: +URAT: 7
11:51:26.749 -> [rdResp]: OK
11:51:33.158 -> AT+UBANDMASK?
11:51:33.158 -> >> AT+UBANDMASK?
11:51:33.158 ->
[rdResp]: AT+UBANDMASK?

11:51:33.158 -> [rdResp]: +UBANDMASK: 0,275063445663,1,275063445663
11:51:33.193 -> [rdResp]: OK
11:51:38.796 -> AT+CFUN=0
11:51:38.796 -> >> AT+CFUN=0
11:51:38.796 ->
[rdResp]: AT+CFUN=0

11:51:38.895 -> [rdResp]: OK
11:51:44.344 -> AT+CGDCONT=1,“IP”,“m2mtrial.telefonica.com
11:51:44.344 -> >> AT+CGDCONT=1,“IP”,“m2mtrial.telefonica.com
11:51:44.344 ->
[rdResp]: AT+CGDCONT=1,“IP”,“m2mtrial.telefonica.com

11:51:44.377 -> [rdResp]: OK
11:51:49.903 -> AT+CFUN=1
11:51:49.903 -> >> AT+CFUN=1
11:51:49.903 ->
[rdResp]: AT+CFUN=1

11:51:49.903 -> [rdResp]: OK
11:51:55.189 -> AT+CGDCONT?
11:51:55.189 -> >> AT+CGDCONT?
11:51:55.189 ->
[rdResp]: AT+CGDCONT?

11:51:55.222 -> [rdResp]: +CGDCONT: 1,“IP”,“m2mtrial.telefonica.com”,“0.0.0.0”,0,0,0,0
11:51:55.222 -> [rdResp]: OK
11:52:58.880 -> AT+COPS=?
11:52:58.880 -> Initializing module, this may take 3 minutes…
11:52:58.880 -> >> AT+COPS=?
11:52:58.880 ->
[rdResp]: AT+COPS=?
11:52:59.254 -> [rdResp]: +COPS: (1,“234 10”,“234 10”,“23410”,7),(0,1,2,3,4),(0,1,2)
11:52:59.254 -> [rdResp]: OK
11:53:04.141 -> AT+COPS=1,2,“23410”
11:53:04.141 -> Initializing module, this may take 3 minutes…
11:53:04.141 -> >> AT+COPS=1,2,“23410”
11:53:04.141 ->
[rdResp]: AT+COPS=1,2,“23410”
11:53:28.160 -> [rdResp]: +CME ERROR: no network service

Please could you suggest any changes, perhaps to the band mask? Many thanks,
Julian

Hi @JulianDaley,

It looks like you are getting refused to join the network.
The bands look fine, however you can maybe reduce the bandmask to only use the band of the operator. The AT+COPS=? sees the operator 23410 so connecting shouldn’t be a problem.
Can you do the AT+CSQ command to see how strong the signal is?
If there is a poor signal you can try moving closer to the cell tower.
99,99 = no signal but it can take a while before it picks up the signal if you have multiple bands enabled in the bandmask, less then 10, (10,99) is a poor signal.

Maybe the operator can tell you more information if they do a trace on the IMSI.
With AT+CIMI you can get your IMSI.

Best regards,
Jan

Hi Jan,

Thanks for the reply, it turned out to be a SIM activation issue.

Regards,
Julian.

1 Like