PSM not working as it should - R410 goes to PSM even without SIM

Hello everyone,
we are having a weird problem with PSM on R410 AFF.

I wanted to test PSM and I can confirm it works in the correct way when the module is connected to the network. The module is set to do a network coordinated PSM only (AT+UPSMVER=4) and it successfully receives the requested TAU/Active timers.

The weird part is that the module remembers the timers and it uses them even when it is not connected to the network. I even tested it without a SIM card and the module just goes to the PSM after the active timer expires. This doesn’t make any sense because it is set to use network coordinated PSM only.

I am using a Passthrough code to test this on a SODAQ AFF R410 board with a USB plugged into the SODAQ USB port (the one near the SIM tray):

Module boots…
[2022-02-19_16:26:41:727]+UUPSMR: 0
[2022-02-19_16:26:42:136]+UPSMVER: 4
[2022-02-19_16:26:44:401]+CME ERROR: SIM failure
[2022-02-19_16:26:46:081]+UPSMVER: 4
[2022-02-19_16:27:04:739]+CME ERROR: SIM failure
[2022-02-19_16:27:17:178]+CME ERROR: SIM failure
[2022-02-19_16:27:29:184]+UUPSMR: 1
[2022-02-19_16:31:33:323]+UUPSMR: 0
[2022-02-19_16:31:45:691]+UUPSMR: 1

You can see that the module goes to PSM even without SIM and then wakes up after 4 minutes and goes back to PSM which doesn’t make sense. Even the timers are not right.
The module remains unresponsive when in PSM mode.

I wanted to post this directly to u-blox, but when I wanted to capture additional logs on the Sara USB port, I could not replicate an error if I am connected to the Sara USB port.
I connected to the Qualcomm HS-USB Modem port and got this log:

Module boots…
[2022-02-19_16:34:56:534]+CME ERROR: SIM failure
[2022-02-19_16:34:57:433]+UUPSMR: 0
[2022-02-19_16:35:08:221]+UPSMVER: 4
[2022-02-19_16:39:17:062]+CME ERROR: SIM failure

You can see that the module doesn’t enter PSM and I am assuming that it could be a hardware thing.

AT+UPSV is set to 0 so UART should remain active.

This problem is preventing me to write an application with the use of PSM because this also happens between connect procedure and it interrupts everything. I assume if I lower the Active PSM timer it would also happen sooner.
Any advice?

Best regards,

Dear @Mihael_King,

Did you also do the following command?

See this page for all commands to disable related PSM features:
Passthrough - SODAQ Support pages

Beste regards,

Dear @Jan,
the command turns PSM off. The device works ok with PSM turned off, but in this project I would like to use PSM to achieve long battery life.
I would like to avoid turning off the module, because registration takes awhile and consumes a lot of energy.

Best regards,