No update device AllthingsTalk

Early last month I obtained the Vodafone starterskit with Sodaq ARF/SARA. Following the instructions that worked in one go. I have created other devices and other playgrounds. I was able to access and update those devices last week. But starting this week, none of the devices are updating, no debug messages in Allthingstalk. I have turned on debug messaging in the driver and all seems to be working without an error. I see it has signal, it connects, I see an IP assigned and see the right AP. I have reloaded the original Vodafone firmware and see it is sending data, but no update on Allthingstalk. I have reached out to both Vodafone and Allthingstalk support, but no response so far. Is there anyone who experienced that same or has some advice what to do ? Is my starterskit subscription expired ? how to check and how to update ?

Hi @paulvha,

Did you enter your token in the menu after reloading the firmware?

Best regards,

Hi, yes I did. the full token is : vodafone:4UZzixeM0tWOG0lqFxpT2LJCjR7oGDWKk3wxNya
after changing with att = vodafone:4UZzixeM0tWOG0lqFxpT2LJCjR7oGDWKk3wxNya
i get the confirmation: att=vodafone:4UZzixeM0tWOG0lqFxpT2LJCjR7oGDWKk3wxNya
Configuration changed

The display will show : All Things Talk Token (att=): vodafone:4UZzixeM0tWOG0lqFxpT2LJ

Hi @paulvha,

Please don’t share security details on the forum to not compromise your device data.

I can see that the shared token is actually the wrong token and indeed does not fit in the field.
AllThingsTalk has a lot of unique identifiers and tokens for the different elements.
This Token can together be used in an other way to send data to your device.

However in the Vodafone code your IMEI + Token is used for authentication.
You can find the correct token in AllThingsTalk Settings => Connectivity

Best regards,

Thanks / bedankt Jan
I was aware of the risk around sharing the token, but as this a test only I was OK with that.
I have now taken the token, same as my device ID.

I have changed the format to “json” but still nothing shows up on all things talk. The code being sent : (XXXXX = correct token)

01014470C4BC4AB8 X X X X X X X X { " t " : 2 3 . 0 , " v " : 4 2 7 2 , " o " : " 0 " , " g " : { " l a t " : 5 2 . 3 0 9 4 4 4 4 , " l o n " : 4 . 6 5 8 7 8 3 0 . " a l t " … (only part of the code)

I had made a copy of the information that was sent in first instance (when I got the device and it all worked) The first part : 01014470C4BC4AB8 X X X X X X X X, was the same. So that should be good !

I looked at the IP address and port they are the same : AT+USOST=0,“”,8891…

After selecting payload “cbor”, I see info showing up in Allthingstalk. Back to “json”, nothing shows up… back to “cbor”… works… try hex …nothing… again cbor… works.

Is this code only working with cbor or is there another problem ?

will now try my other devices… those use Json…


Found the root-cause: I was using an IP address that was taken from online example: That was working until last week, but not anymore. The documentation clearly states to use : or Changed to use “” and that solved the issue.

Thanks for your help !


1 Like

Hi Paul,

I’m glad you see at least data with cbor again.

I know that there were some issues with sending json to AllThingTalk.

Do you see the hex in the debug of ATT? I could be that you need to enable the ABCL decoder and add your decoding to successfully decode the data.

Best regards,

Hi there, I am having the exact same issue – I received the kit on 7th April, and it was up any running without much issue here in the UK. It (allthingstalk dashboard) stopped receiving data just before 7pm UK that evening and I have not been able to see anything since. Have rebooted, repositioned etc. Network coverage suddenly gone? Device problem? SIM issue? Allthingstalk issue??

I do not know how to debug this or where to start … can you help please?

Erg. I tried to delete the device and re-add, and now the activation code is no longer accepted :frowning:

Hi @patmolloy,

When a device is deleted, it should free the Activation Code.
Did you retry after waiting a bit?

If you still can’t re-activate your device, please send an email to info at sodaq dot com
Refer to this post, provide your activation code and order number.

Hope we will have you back online soon!

Best regards,

Hi Jan,

You are right … I managed to add it again successfully after a while … must be a timing issue.

So, added successfully again. But still no data.

I need some help trying to debug this … as i say, it did work for a while the first time I activated the device. But then just stopped receiving data in the dashboard for reasons unknown!


Is there any mechanism to …

  1. See if the board is getting a connection to the Vodafone network? Or if I am suddenly out of coverage for some reason?
  2. See if I have run out of SIM allowance? I am in the UK, the SIM seems to be Vodafone NL - could that be an issue? Gigantic roaming charge has resulted in just a few messages putting me over the limit? What is the limit, BTW ?

Thanks all!

Pat. In solitary confinement in South West London :frowning:

Hi @patmolloy,

  1. To see debug information, connect the device to your pc.
    Press the reset button.
    Open a Serial Monitor.
    Send the command: dbg=1 to turn on the debug, and disable the low power.
    Now you will see the debug messages on your screen.

  2. The SIM is indeed from Vodafone NL, it should roam without issues and any extra cost on every EU Vodafone NB-IoT network. If you want us to check the status of the simcard, please send an email to info at sodaq dot com.

Best regards,

Thanks Jan, I will try this. In the meantime I have managed to source some UK SIM cards from a company called Arkessa, who are an MNO built on top of vodafone. The SIMS are branded vodafone, but Arkessa have their own, different APN …

Access Point Name:
MNO - Arkessa LP
APN - [](
Username - arkessa
Password - arkessa
Authentication - PAP

Will these SIMs just work, with the APN being picked up automatically, or are changes required? Or will it just not work at all?



Hi @patmolloy,

Changes are required, the program does not read the APN from the SIM.
The APN has to be set in the menu. Reset the board, open a Serial Monitor and update the settings, the menu will disappear after 30 sec of no input.

Best regards,

Great. Thanks. Where is all of this documented? Then I can stop bothering you :slight_smile:


Hi @patmolloy,

The idea from Vodafone was, that you buy the kit and don’t change the settings/software.
All required documentation is on this site:

Just keep bothering me if you need more information. You need to be allowed to do what you want with the device.

Best regards,

Jan, thanks. I followed all of this and it worked perfectly for several hours. Then I just stopped receiving data into the allthingstalk dashboard. And I am still stuck … I have emailed in to sodaq to see if the SIM is still Ok. Then I have these other SIMs from a UK provider.

There are two micro USB ports … to change the MNO which one am I using and at what speed?


Hi @patmolloy,

There is one port directly connected to the R4 module, with this port you can do software updates to the module.

The port next to the sim slot is to upload a sketch, this port needs to be connected when you want to change settings in the menu.

Best regards,

Ok, I see all of this now. For reasons totally unknown, I inserted the original SIM again (i.e. the one supplied with the kit) and it seems to be working … I have no idea whether this was a network issue or a SIM issue. Whatever the case, I am getting data every 5 mins at the moment.

I see this on debug (truncated list)

  APN                         (apn=): nb.inetd.gdsp
  Force Operator              (opr=): 0
  Network (LTE-M=7, NB-IoT=8) (rat=): 8
  Band Mask                   (bnm=): 524288
  Server URL/IP               (url=):
  Server port                 (prt=): 8891
  GPS (OFF=0 / ON=1)          (gps=): 1
  Debug (OFF=0 / ON=1)        (dbg=): 1
  High temperature trigger    (hgh=): 29
  Low temperature trigger     (low=): 10

On-the-move Functionality
  Acceleration% (100% = 8g)   (acc=): 25
  Acceleration Duration       (acd=): 0
  Accelerator Trigger
    Sensitivity (1-50)        (act=): 10
    Back-off time (sec)       (bot=): 10

Enter command: init

So it’s possible to set the APN to something different. The UK SIMS I have have an APN that requires username and password. I don’t see those options here. Does that mean I cannot get it to work? Or are there some AT commands that will allow me to set those?

Thanks again.