Mbili rev.6b and GPRSBee rev.6 library incompatibility?

I have the latest versions of both the Mbili (rev.6b) and the GPRSbee (rev.6) with a SIM800H chip. The various versions of your library will not compile the example code, and I have no idea how to proceed. We are trying to send sensor data to ThingSpeak or a private server, but we are unable to communicate with the GPRSBee. I am using version 1.6.5 of the Arduino IDE and Sodaq version 1.2.0 of the GPRSBee library.

Thanks,
Stephanie

The examples which are included with the GPRSbee library are a bit out of date. This mainly relates to the intialisation process.

This should work for initialisation on the Mbili:

gprsbee.initAutonomoSIM800(Serial1, -1, BEEDTR, BEECTS);

The old method of specifying which switching mode to use has also been removed.

Also, you might have issues with using the 1.6.5 version of the Arduino IDE as that version is several years old now. Additionally, make sure that the version of the Sodaq AVR board files is up to date.