LSM303C not working on new boards

Hi,
we just got 2 new boards ‘NB-IoT shield’ SARA N211 with all possible sensors. The boards are Revision 3b like our older board, but LSM303C on both new boards are not working! To be exact, only temperature is readable. All other sensors including the SARAN211 work as expected. Can somebody please tell me what has changed? The only thing I can see under the microscope is, that the chips (LSM303) look different.

Thanks in advance
Gunther

And to be a little more precise according the problem. Initializing the accelerometer seems to be the problem. If I put the ‘return’ statement before these lines, the’ begin routine’ returns successful but only temperature is readable!

Kind regards
Gunther

////////// Initialize Magnetometer //////////
// Initialize magnetometer output data rate
successes += MAG_SetODR(modr);
// Initialize magnetic field full scale
successes += MAG_SetFullScale(mfs);
// Enabling block data updating
successes += MAG_BlockDataUpdate(mbu);
// Initialize magnetometer X/Y axes ouput data rate
successes += MAG_XY_AxOperativeMode(mxyodr);
// Initialize magnetometer Z axis performance mode
successes += MAG_Z_AxOperativeMode(mzodr);
// Initialize magnetometer run mode.
successes += MAG_SetMode(mm);
////////// Initialize Accelerometer //////////

// Everything after this point in the ‘begin’ routine will fail

// Initialize acceleration full scale
successes += ACC_SetFullScale(afs);
// Enable block data updating
successes += ACC_BlockDataUpdate(abu);
// Enable X, Y, and Z accelerometer axes
successes += ACC_EnableAxis(aea);
// Initialize accelerometer output data rate
successes += ACC_SetODR(aodr);

return (successes == IMU_SUCCESS) ? IMU_SUCCESS : IMU_HW_ERROR;

Ok, I think I solved the problem by myself :slight_smile: After checking LIS3 for pin compatibility, I just tried LIS3 Lib et voila it’s working. Sodaq has changed the chips without a notice???

Hi,

I’m glad you found the issue (:

All the differences between V1 and V2 can be found here:
http://support.sodaq.com/sodaq-one/sodaq-one/#one-vs-one-v2

Best regards,
Jan

Yes, I saw this, but I don’t have a ‘Sodaq One’ board :slight_smile: Mine is a Sodaq NBIoT shield

and, they are same board revision rev. 3b, with different chips!!!