LoraBee rn2483 not working on Mbili rev6b

Hi,

We’ve ordered a Mbili Lora Kit. However, we can’t get the LoraBee functioning.

Even with the example code it keeps saying ‘no response from the device’

I think the LoraBee is broken?

Can you try a serial pass-through sketch which echos everything between the two hardware serials on the Mbili.

You can use this sketch, you will just need to change line 20 so that it uses 57600 instead of 9600.

Then open the Serial Monitor (at 57600, both line endings enabled) and try typing “sys get ver”.

Thanks, tried. Nothing comes out of the serial monitor… No output… I assume the loRa chip is broken?

Fixed, started to work a few days later… strange…

Hello,

I have the same problem.
Mbili rev.6b with lorabee.

I tried the passtrough code but it doesn’t show anything.
It seems the lora chip isn’t repsonding to anything.
Could it be broken? It just arrived today :frowning:

Regards,

The RN2483 Module has a bug that when you load new code to any board it gets stuck sometimes.

Disconnect the board from any power (usb and or lipo) and reconnect the power source to solve the problem.

Without usb connected, it always works.
With usb connected, sometimes.
eitherway, hard to debug with this bug…