JTAG Blackmagic Probe has anybody used

Hi Im trying to get the JTAG working on the Autonomo and what tools.
I was wondering if anybody else has tried this - or any hints.
I have two Autonomo Rev5 recently purchased with 10pinJ1 (thankyou thankyou).

I’ve started with the BlackMagic Probe (but also have a MultiLink Universal, NXP LPC-Link2 …)
I plugin the JTAG cable and then BlackMagic USB which enumerates successfully.
Then plugin the Autonomo USB to power it.
I start in platformio/VisualStudio and in the terminal bring up
C:\Users\ user\ .platformio\packages\toolchain-gccarmnoneeabi\bin\arm-none-eabi-gdb.exe
GNU gdb (GNU Tools for ARM Embedded Processors) 7.10.1.20160923-cvs
Then type
(gdb) target extended-remote COM8
(gdb) monitor version
Black Magic Probe (Firmware v1.6) (Hardware Version 3)
(gdb) monitor jtag_scan
Target voltage: 3.3V
JTAG device scan failed!

I could only find the Rev3 schematic - https://support.sodaq.com/sodaq-one/autonomо/schema/
but it looks like it should suppport JTAG.
https://1bitsquared.com/products/black-magic-probe
https://github.com/blacksphere/blackmagic/wiki/Getting-Started
https://docs.platformio.org/en/latest/plus/debug-tools/blackmagic.html
https://gitter.im/blacksphere/blackmagic
https://github.com/blacksphere/blackmagic/blob/master/src/target/samd.c

Oh I guess I found its SWD (not JTAG) so when i use
(gdb) mon s
Target voltage: 3.3V
Available Targets:
No. Att Driver
1 Atmel SAMD21J18A (rev D)

Now next issue is how to connect it to the platformio/BlackMagic … but I should probably take that question to forum.sodaq.com - seems like a similar question at https://community.platformio.org/t/pio-debugger-works-like-a-charm-using-blackmagic-probe-first-time-only/6727

Did you ever figure out how to get Black Magic Probe to with platformio or did you give up? Everything I’ve tried to do with PIO has been hell.

Hi Kritischer,

I’m using pio with an atmel ice for debugging and it works great. If you want to use pio and use its debugging I’d strongly recommend getting an ice instead.

Regards,
Thom