Issue with updating R410M firmware

Hi,

I’m currently trying to update the firmware on the R410M module, but I’m experiencing some problems. I’ve followed the steps mentioned in https://support.sodaq.com/Boards/Sara_AFF/#r4, but instead of a successful update I get:

"Using USB port

Processing ‘SARA-R410M-02B-01-L0_0_00_00_05_08.dof’
Please TURN ON the device and don’t disconnect power supply
Waiting for device…

WARNING! DEVICE NOT FOUND!
Please TURN OFF and then TURN ON the device
Waiting for device…
Error occured!
[Can’t find device!]

Please TURN OFF the device and press ‘Start’ to install the firmware
"

When I open device-manager I see it doesn’t really recognize the module over USB, and instead shows it as “Qualcomm CDMA Technologies MSM”, which it displays 4 times as duplicates. I’ve tried several different boards, all have the same behaviour.

I think the issue is that my PC doesn’t have the correct drivers, but installing them manually doesn’t seem to work either. Any help with this would be greatly appreciated

Hi Rob,

You put the file in the correct folder I see.

Did you reboot your pc after installing the EasyFlash tool?
Did you open EasyFlash as administrator?

Connect the board to your pc
[ If you have version with the 2nd USB on your board ]
After connecting the USB cable, quickly press the reset button twice to put the SAMD into bootloader mode.
This way your sketch will not run and doesn’t send commands to the sara module.
[ if you have version with the solder pins ]
load the passthrough sketch, via the normal USB port next to the sim card holder.

Press start to upload new firmware.

Hope this helps!

Best regards,
Jan

The issue was solved by installing the correct drivers for the Qualcomm CDMA Technologies MSM, provided by Ublox on https://www.u-blox.com/en/product-resources/field_file_category/driver-221