HWEUI is set to 0

Hi,
We have a sodaq one device.
We can not retrieve the HW EUI, it is set to 000000000000000.
So we are not able to use our device.
Does any one already has this issue ?

Hi,

It seems that its the combination of the tracker software with board files 1.7.0
Can you go back to the board files 1.6.x ?

We are investigating the issue.

Regards,
Jan

Thanks for your quick answer.
I tried with 1.6.0, but result is the same.

Can you try with 1.6.9, 1.6.10 or 1.6.11?
And after you have uploaded the code, can you give it a power cycle?
Just disconnect the board from usb / battery for 10 seconds.

Hi,
Thanks for helping.
I tried again (with 1.6.9)
HW is empty
Result is here :
Enter command: EUI
Initializing LoRa…

Commands:
Reset DevAddr / DevEUI to the Hardware EUI (EUI):
Commit Settings (CS):

Settings:
GPS (OFF=0 / ON=1) (gps=): 1

Hi,

Can you after uploading disconnect the usb cable and battery if connected?
Reconnect it after 10 seconds.
Then open the serial monitor.

A power cycle after re-programming the device should fix the communication to the rn module.

Regards,
Jan

Thanks for your support.
Now it is OK. I retrieved info in TTN…

1 Like