Explorer: setting SF problem on RN2483

Hi all,

I am having trouble setting the RN2483 SF on my Explorer-board; i want to set the spreadfactor to 10.

I implemented this in my setup-code:

  loraSerial.println("radio set sf sf10");
  delay(100);
  char buff[10];
  memset(buff,0,sizeof(buff));
  loraSerial.readBytesUntil(0x20,buff,sizeof(buff));

and get:

Communication to LoRaBEE successful.
set fs10 ok

as a result (looks good)
but… still my TTN-console says:

  "modulation": "LORA",
  "data_rate": "SF7BW125",
  "coding_rate": "4/5",

to make things worse: when i use

  loraSerial.println("radio get sf");`

after sending (to show if i really DID change the setting of SF)
it shows: SF12

I am lost, what to do? (what am I doing wrong?)

THNX for the help…

Hello Adri,

The problem is that you are mixing “radio” commands and “mac” commands.
(I will assume you’re using “mac” commands by the fact that you’re connecting to TTN)

The “radio” commands are just there for static test set ups and gives low level access to the radio drivers - the mac layer is bypassed.
When you use the “mac” layer, it takes priority and will over-rule any radio state.

To do what you are trying, use instead “mac set dr 2”.