Explorer, Arduino ide freezes when trying to upload code

I got a new Explorer board and followed the directions on getting started

Board selection and port selection in the Arduino IDE seems to work fine.

I can successfully request board information via the Arduino IDE.

However, when I try to send a simple program (e.g., Blink) it compiles OK but this just freezes saying
“uploading…” in the ide. Seems like a USB issue. I tried a different computer but had the same problem.

Any suggestions - I feel like I missing something fundamental regarding the use of the USB port.

Sorry for the newbie question.


Hi @micromet,

Before uploading can you double press the reset button to manually put the device in bootloader mode?
In the Arduino IDE you have to select the new COM port.
You should now be able to upload a new sketch to your device.

Best regards,

Thanks, it worked.
Also, What is the function of the slider switch on the edge of the board (Ext, Int)

Hi @micromet,

With the slider you can choose the internal battery (coin cell) or external battery, jst connector for a lipo battery.

Best regards,