Cow Tracker V2 (SODAQ One V3) on AS923

Dear Sodaq Forum

I’m from Japan.

[ Issue ]
I’m trying to connect the cow tracker v2 to TTN because I got this device a couple of weeks ago.
Unfortunately, the node could be NOT connected to TTN.

[ Background / What I did ]

  • I saw / checked some related posts here, github pages, SODAQ Support pages.
  • I connect this node via USB(serial) by “screen” command. I could see the messages via the terminal.
  • Based on the node information, I registered this node on TTN.
  • The tracker firmware version was old. It’s 1.1.0. So I updated the latest one based on the github page. Now the latest one is 6.0.0.
  • After the update, this node is not yet connected to TTN.
  • I found I should need to apply AS923 firmware to this node. Base on the githab page,
    https://github.com/SodaqMoja/RN2483FirmwareUpdater

[ Question ]
Q1. How do I install the latest tracker application with AS923 firmware?
Q2. How can I confirm what frequency plan is applied on the board?

[ My environment ]

  • Mac OS Catalina 10.15.17
  • Arduino IDE 1.8.14
  • Cow Tracker v2 ( SODAQ One V3)
  • TTN: The Things Stack V3 community edition

Hope someone give me supports.

Thanks in advance
Kenny

Hi @kennyA,

You actually downgraded.
SodaqOne-UniversalTracker-v3 v6.0.2 is older than Sodaq_Universal_Tracker v1.1.0
The version number can be a bit confusing, you can read more about it here:
Tracker - SODAQ Support pages
I recommend you to re-upload Sodaq_Universal_Tracker v1.1.0 with the recommended changes.

The RN2483 modules use by default the first set of sub-channels
The RN2903 modules use by default the 2nd set of subchannels.
These are the default for EU en US boards.

For the AS923 you want update these frequencies.
You can do this in Sodaq_RN2483.h
Change #define DEFAULT_FSB 2 to #define DEFAULT_FSB 1

You can now upload the sketch to your board.

Best regards,
Jan

Hi @Jan

Thank you very much for the great advise.
So sorry for my mis-understanding as for the software version.

Based on your advise, I revised everything.
Then the device works well now on AS923 here.

Again, much appreciated.

Warm regards,
K

1 Like