Can't send udp packets

Hello,

I have the SodaQ Sara R410. I m running the following commands and everything seems be right.
But when i send a udp message to my server in the port 3000 nothing is receiving. Below are the commands and the response:
AT+URAT=8
OK
AT+CMEE=2
OK
AT+CGDCONT=1,“IP”,“dev.sodaq.com
OK
AT+CFUN=1
OK
AT+URAT?
+URAT: 8
OK
AT+CGDCONT?
+CGDCONT: 1,“IP”,“dev.sodaq.com”,“10.0.0.137”,0,0,0,0
AT+COPS=?
+COPS: (2,“202 05”,“202 05”,“20205”,9),(0,1,2)
OK
AT+COPS=1,2,“20205”,9
OK
AT+CSQ
+CSQ: 12,99
AT+CEREG=2
OK
AT+CEREG?
+CEREG: 2,5,“1399”,“6CE33”,9
OK
AT+CGPADDR
+CGPADDR: 1,10.0.0.137
OK
AT+USOCR=17
+USOCR: 0
OK
AT+USOST=0,“My_IP_Server”,3000,4,“Test”
+USOST: 0,4
OK

In my server doesnt appear anything when i send the udp message “Test”. Can anyone know what is going wrong?

Thank you.

You should end with sending AT+USOCL=0

https://support.sodaq.com/sodaq-one/sodaq-sara-r410m/

I try end it with AT+USOCL=0 but the result is the same…No udp message received in my server.
I think it doesnt matter if i close the socket or not.

Have you checked it it works with the Ublox echo server?

Your firewall might be blocking UDP traffic. Also if your server has an internal firewall that might be blocking too.
Can you send UDP packets to your server from your computer?

Yes i can send UDP packets from my computer to server. It was the first thing i checked. More specific i run in server :
nc -u -l 30000
and in my computer :
nc -u my_server_ip 30000
And when i type something in my computer i can see it in my server. So i suppose my server dont block UDP traffic.

I have been testing the same on the T-Mobile NB-IoT Network.

According to T-Mobile, you can’t send messages directly to your server. The same for the Vodafone NB-IoT server.
So you have to send to their server, and forward the messages to your HTTP Server.

Just to be clear. When you say “their server” you mean in a Vodafone server? and if yes why in http://support.sodaq.com/sodaq-one/sodaq-sara-r410m/ the command
AT+USOST=0,“37.97.216.22”,3000,4,“Data” says that i have to declare my_ip_server.
FYI i have access (with limited rights) to m2m vodafone platform and i check the traffic of my sim card. I see there some downloads and uploads traffic :
Data Session
Finished 15 hour(s), 47 minute(s) ago
Download: 676 B. Upload: 696 B
But i cant understand where these data have been sent.
i m just ask you all questions cause i m so confused. I would be greatful if you could be more specific please.
Thank you very much

Yes I do mean the Vodafone server.

Are you using LTE-M or NB-IoT?
I’m not sure if it is possible with LTE-M to send directly to your own server, but with NB-IoT it isn’t.

My knowledge about the Vodafone server is minute.

I use NB-IoT.
Before some posts you told me to check if it works with Ublox echo server.
I saw this manual https://www.u-blox.com/sites/default/files/products/documents/TestServerForSocketOperations_AppNote_(UBX-14005690).pdf
And i check the “UDP echo service example” and it works fine.
Is there any occasion that my_ip_server is not whitelisted from Vodafone?

Nope, that wasn’t me :joy:

I don’t now the details of the Vodafone server.
But after mailing with T-Mobile, they told me that it will not be possible to send directly to your own server.

yes you are right…Was another(Krolken)…
I think i m dizzy…:stuck_out_tongue:
Thanks anyway Alex

So you can send to Ublox server but not your own? Shouldn’t you have access to all of internet?

Yes i Should. The IP of my server is in the university network area. The only explanation is that my IP is not whitelisted.
Have you any other idea what could go wrong? I m in dead end…

Sorry but maybe a stupid question:

When you are testing from your own laptop. Is that a university laptop or on the university network?

Maybe your laptop is trusted in or outside of the network but a random request from internet is not and is blocked.

I will tell you what cheks i did so far and which was successful

  1. From my_laptop(inside university network) to my_university_server --> successful
  2. From my_laptop(outside university network) to my_university_server --> successful
  3. From outside_university_server to my_university_server --> successful
    4.From Sodaq_Sara_R410 to ublox-echo_server --> successful
    5.From Sodaq_Sara_R410 to my_university_server --> NOT successful
    6.From Sodaq_Sara_R410 to outside_university_server --> NOT successful
    The Vodafone Antennas for NB-IoT area is around the university. So when i send from Sodaq Sara anything i have to be inside the university area.
1 Like

@sakxam,

I did dig into the problems with your sim.
Vodafone is only allowing some servers.

I will send you an email how we could solve your issues.

Kind regards,
Jan

The problem was that my Ip was not in whitelist.
When Vodafone make whitelist my IP i start send data to my_server and i received them successful
So the Problem solved.
Thank you all for the help!!
:slight_smile:

2 Likes

@Jan could you send me a similar email, on how to white-list our server? We are running in to the same problems.

Dear @SanderV,

AllThingsTalk, SODAQ test server and the Ublox echo server are the only whitelisted IPs.
As SODAQ we can’t add any IP addresses to the whitelist, please contact Vodafone about adding your IP addresses to the whitelist.

Best regards,
Jan

Thanks, we will work it out with Vodafone.

1 Like