Cannot activate on AllThingsTalk

I have received my SARA AFF N211 NB-IoT development board with Vodafone SIM. I am following the Sodaq guide for the Universal Tracker. When I try to activate my device on AllThingsTalk, I receive an error of “invalid activation code”. I have contacted support directly and confirmed that my activation code is correct for my IMEI and SIM.

Please can anyone help?

Hi @amgreen,

I believe the issue is because you login to the wrong server.
For the Vodafone kits there is a different URL
https://vodafone.allthingstalk.com/signin

I have the Vodafone URL to the support pages.

Best regards,
Jan

That worked! Thank you so much.
Please could you update the Universal Tracker instructions to include this?
https://learn.sodaq.com/Boards/Sara_AFF/Examples/universal_tracker/#getting-started

Hi,

I have tried to use the activation code provided to me by support on vodafone allthingstalk portal but it says invalid activation code, please guide me if I am missing something.here. I am using the right vodaphone  allthingstalk though..

Please find a screenshot of the screen attache.

Hi @zaindroid,

I will send you an email with the details.

Best regards,
Jan