Bluetooth Low Energy (BLE) Shield

I have updated the Microchip_RN487x library and examples to work with the Sodaq One BLE shield.
And added the schematic to the support pages:
http://support.sodaq.com/sodaq-one/ble-shield/

Shop:
https://shop.sodaq.com/en/sodaq-one-ble-shield.html

If anyone has some questions about the BLE shield let me know :smile:

Hello,

Can you confirm that its not possible to put the RN487 into a central Role. I would like to connect to a BLE peripheral ?

Kind thanks,
Serge

Dear Serge,

It is possible to put the bluetooth module in a central role.
In the RN487x library is a peripheral example.

Kind regards,
Jan

Hi Jan,

How does the hwSleep and hwWakeUp command work ? I’m scanning the neighbor BLE devices every 10 minutes for 30 seconds and want to go sleep between scans. For now, when I call hwSleep() the BLE module still send me scan results…
My solution is to just call the stopScanning function, but i’m not sure the power consumption go as low as in sleep mode.

Regards
Alexander

I have been experimenting with my module and so far its un-responsive. I have connected directly to my Mac via an FTDI converter at 3.3V for both Vcc and IO. No matter what I try the module remains unresponsive. Using Coolterm.

Per Datasheet the module should be communicating at 115200 but I have also tried other baud rates.

Any thoughts ?

Thanks

OK so I connected it back up to the Sodaq ONE and ran some example code and that worked … so I must be doing something wrong :slight_smile:

The only reason I want to connect directly to a Serial Coms program on my laptop is that it will be far easier to test the commands

So just to “close” this thread. I have successfully be able to connect to a BLE peripheral and gather some data. I seem to have found a bug with the RN4871 however but awaiting confirmation from chip manufacturer.

For some reason the CI command never returns an “AOK” response even though if I stick a delay here instead of waiting for the AOK response it works.

Any updates on the results?

I found MICROCHIP to be very helpful with these type of questions.

http://www.microchip.com/wwwproducts/en/RN4871

Hi,

Sadly I have had no help from Microchip so have abandoned the project for the moment.

Thanks,
Serge

Never give up, you never know who is around the corner. :sunglasses:

I agree but with limited time for each individual project it gets very frustrating stumbling upon very basic bugs over which you have no control and questions in forums (Microchip) and to support (Microchip) go un-answered…

They respond to me.
Give me support and fix Atmel Studio on my request.

I think they are getting better day by day.

Remember REFACTORING
Atmel with MICROCHIP may take some time.

It’s the only way to go.
4 me. :sunglasses:

I don’t work for anyone.
I just have an opinion and express it, even when not wanted.

To make a point, I may add.

Enjoy IoT, when it stops being fun, just put it down for a few days.

i’m trying to pair 2 sodaqs and exchange data betewen the 2 devices, any help on how to procede would be helpful .

Thank you

Little update even though its been a while… (good thing I was not in a hurry)

For some reason the CI command never returns an “AOK” response even though if I stick a delay here instead of waiting for the AOK response it works.

So this turns out to have been a firmware bug which has been corrected in the latest firmware 1.28.3

Unfortunately now I bump into two additional problems.

  • Randomly receiving a DISCONNECT from the RN4871
  • Not sure yet how to read the inbound data stream after issuing a “CHR” Read request using the provided Arduino Library.

Slowly thinking the Laird RM1X is the way to go…

Sorry for my ramblings…

Serge