Autonomo - not responding, cant upload code

I have a Autonomo from kickstarter and it had been working when I last put it way. I have a new project that i think it might lend itself to but i cant get the device to receive code.

I have tried the following on Windows, Mac and Linux.
Connected the board. it connects as /dev/ttyACM0 and 1
When trying to upload a blank project (just the default code, just comments) the upload fails An error occurred while uploading the sketch

I have tried the reset pin within 500ms and see that it indeed goes from 0 to 1 port. The upload still fails when on the 1 port.

When looking at the board details under port I see that the IDE thinks that the board is a SODAQ ExpLoRa, VID: 2341, PID: 004D, SN: (null)

With out access to a programmer is there a way to recover from this?

There is a reset button on the Autonomo.
If you press it twice quickly you can put in manually into bootloader mode.

You should get an other com port when it’s into bootloader mode.

Let me know if this solves your upload issue.

Best regards,

In my original post I tried to indicate that I have tried doing this. I do see the device go from port 0 to 1 but still get upload errors.

Can you update to the latest Arduino IDE?

Can you check if you have the correct / new board file url:
AVR (moya, mbili, tatu,…)
SAMD (Autonomo, one, explorer)
We seperated the two architectures.


I am using the samd url and just to make sure I copy and pasted the url above with no change.

I have version 1.8.5 that is the version that I started testing with. This is a similar experience on Mac, Linux and windows as well. I’m assuming the official release is what you are talking about if you can tell me a daily build or build number I can try and test with that.


I believe it is only possible to overwrite the bootloader if you use a programmer or are working with the NVM directly.

Here are a suggestions of things you could try (I understand you may have tried some or all of these steps already):

  1. Disconnect any attached peripherals or components.
  2. Disconnect any power source other than the USB.
  3. Make sure to close any other terminal that you may have opened (another copy of Arduino, the Serial Monitor etc).
  4. Double tap the reset button to put the board in bootloader mode (make sure to only tap twice as a third tap will put the board back into normal mode).
  5. Ensure that you have both the correct board and port selected in the IDE.
  6. Possibly try a different USB cable.


Thanks for the suggestions. I have tried all of them with no success. Is there a process or service Sodaq has to send this back to get it flashed? I would hate to throw away something that is most likely just a firmware flash away from working.

Or is there a process that can be followed to use a programmer to flash the device? What programmer and are there documents for this process?

Thanks in advance,

Hi Joe,

Yes you can use a programmer to write directly to MCU’s non-volatile memory. This can be done directly from the Arduino IDE. You can either burn a sketch directly, or you can also burn a bootloader for programming it over the USB connection.

You will need a SAM compatible programmer with a 10 pin SWD connector.

I personally use the Atmel-ICE, it is a bit expensive but it is definitely a useful piece of kit. Alternatively, there are other generic programmers which will also work, however, you will need to check the compatibility specifics.

One thing you could try is to enable verbose output (from the Arduino Preferences) for the upload process. This might provide some useful information as to what is causing this issue or at what point the process is failing.