AT command passthrough stopped working

Hi

recently I worked with the AT_passthrough on the SARA AFF R410M rev2 and everything worked fine.
The next day I wanted to continue but I did not get any response on the serial port anymore. There is no answer even on the “ATI9” command. Uploading the sketch again does not help.
When I upload another basic sketch like measuring battery voltage and temperature then everything works like expected including the serial port.

I am wondering if the SARA module got stuck in an undesired state when I removed the power supply. I read now in the SARA system integration manual that the supply should not be removed before the SARA module has been cleanly shut down by a AT+CPWROFF command.
I tried toggling the voltage pin on the R4xx as #monalisan suggested with no success.
Other error causes may be possible, too.

  • What can I do to get it running again?
  • What is your experience with “unclean” shut down, is that critical to avoid?
  • Any tips on debugging problems with the SARA module on the board are appreciated.

Thanks for your help
Uta

Goodmorning,

To be honest, I have never shutdown the Sara AFF R410M using the AT+CPWROFF command. :sweat_smile:
When you use the nbiot_serial_passthrough sketch from the sodaq library, does the serialport working then?

Thanks for your quick reply :slight_smile:
No it does not work :frowning: (no warnings or errors during compile and upload)

Hmmm, I do know that I have to send an AT-Command earlier than 15 seconds after uploading the sketch. Otherwise I can’t communicate with the device anymore.
How much time is there between you sending the AT-Command (for example ‘AT’) and uploading the sketch?

I started the serial monitor and send a command directly after upload and it does not work. I never noticed before that that was an issue.

What’s the first command you send? Did you try sending just ‘AT’?

I tried, ATI9 and just AT and in both cases it does not work. Is it correct that the serial monitor has to be started after upload? When it is open from before I get an error " Error opening serial port ‘COM3’ " under uploading

Yes that’s correct, it uses the same COM Port for uploading the sketch.

You could try clicking twice on the reset button and uploading the sketch to the other COM Port that should appear.

I got uploaded through the other port (now COM4 - Genuino Zero Bootloader). After uploading the port changed back to COM3 again. I get no response in serial monitor on COM3 and not on serial monitor on COM4 either.

But the COM3 port is available for monitoring?
Which baudrate are you using?

I am a bit confused about your question - The COM3 and COM4 are not available at the same time.
I checked the COM port in the Windows device manager on my PC. The port changes to COM4 after double clicking the reset and changes back to COM3 after upload.
I use the Arduino IDE with serial monitor and also tried PuTTY as serial monitor.
Baud rate is 115200 in the sketch and in Arduino IDE but my Windows device manager say 9600

Same problem here. My two SARA AFF R410M’s were happily sending UDP messages each 15 minutes, but yesterday within hours of each other, they both stopped working. Both my own sketch and the serial passthrough sketch get no response anymore from the modem. I’ve tried to reset it with the SARA_RESET pin, but it didn’t help (would the modem not be reset anyway by cutting power?) I have never used the AT+CPWROFF command though.

This seems like the same problem @Henrik_Sihm and I are having.

I have one module that works with passthrough but when I uploaded the passthrough on some other ones I get no response.

But it works if you upload a program that send data if you put a program on the arduino part.

It looks like the same problem I have with the AFF R410M Rev3 board I use.
It worked until the lipo-battery dried and after reloading the battery everything on the module works except the R420M module.

I tried a passthrough sketch found on: https://github.com/SodaqMoja/Sodaq_nbIOT/blob/master/examples/nbIOT_test_udp/nbIOT_test_udp.ino
This was the result:

Initializing and connecting…
15:30:23.099 -> [init] started.
15:30:23.099 -> Enabling sara R4XX functionality
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
[rdResp]: timed out
15:30:32.884 -> Failed to connect to the modem!
15:30:32.884 ->
15:30:32.884 -> Sending message through UDP
[rdResp]: timed out
15:30:38.068 -> Failed to create socket

After this I tried to update the firmware of the R410M using the 2nd USB on my Rev3 board.
This is not working. The port gets installed on my PC but updating the firmware does not work.

I hope we can find together a solution.

Best regards,

Punaise.

I hope we find a solution. I had no battery involved when it went wrong.

Best
Uta

Hi,

Same problem here. On my SODAQ SARA AFF R410M rev3 board the modem, just out of nowhere, stopped responding. I tried uploading differend programs but nothing seems to work any more. Also the 2nd USB port cant get a response with the m-center tool. Could this mean the modem just died? Or is something else going on here? It happend when i was testing my board and was powered bij USB. I have no idea what else i could do now. Hopefully someone could find a solution.

Kind regards,

Karst

This all sounds like a hardware issue to me, though I thought the SARA’s are quite robust. You could check if the V_INT pin still gives 1.8V. If not it’s probably dead. Perhaps measure the current and see if there’s any anomilies there? I’m quite positive this isn’t a software issue.

Well, the V_INT value looks normal, 1.8V. Also in the software I can see that SARA_STATUS is HIGH. I checked the currend draw and that also looks normal 60~66 mA when modem is on. I can also see the modem turning on and off as I programmed it. I even checked the serial connection from the microcontroller, to the levelshifter, to the modem and that is ok as well. I just dont get an answer from the modem. What else could it be that I’m missing?

Last think I can think of is doing a Firmware update. That will reset all settings to default, even the non volitile ones I believe. If it’s an issue with settings, that will likely solve it.