After a couple of weeks success, Sodaq ONE now always returning "LoRa init failed", and gets DENIED

I have a strange situation. The Sodaq ONE I have and worked a couple of weeks ago now doesn’t work anymore… When booting the Sodaq ONE I always get “LoRa init failed!”

My gateway is a TTN gateway (rPI + IMST Ic880a concentrator) which I also used during my initial testing a couple of weeks ago. The combination didn’t change, I left the Sodaq ONE without power for a couple of weeks and now picked it up again to get started with the new Tracker project (v 3.0)

I tried everything: Rebooting my gateway (warm, cold), refreshing the Tracker project several times. I even ended up removing my application on staging.thethingsnetwork.org and recreating a new one. I registered my Sodaq ONE again and set the new keys generated here in the project.

Strange thing is: the Sodaq ONE gets accepted on the network, the application dashboard flags the device as Activated and its device address is assigned. However, no single byte of payload is coming in.

What can be wrong here? Is there a possibility of debugging the communication stream between the SAMD and the Microchip module on the SODAQ ONE?

I enabled the DEBUG-compiler directive for the lora module and I get:

Initializing LoRa…
[initOTA]
[init]
[sleep]
[wakeUp]
[resetDevice]
[expectString] expecting RN.(RN2483 1.0.1 Dec 15 2015 09:38:09) found a match!
The device type is RN2483
[setPowerIndex]
[setMacParam] pwridx = 1
[expectString] expecting ok.(ok) found a match!
[setSpreadingFactor]
[setMacParam] dr = 5
[expectString] expecting ok.(ok) found a match!
[setMacParam] deveui = [array][expectString] expecting ok.(ok) found a match!
[setMacParam] appeui = [array][expectString] expecting ok.(ok) found a match!
[setMacParam] appkey = [array][expectString] expecting ok.(ok) found a match!
[setMacParam] adr = on
[expectString] expecting ok.(ok) found a match!
[joinNetwork]
[expectString] expecting ok.(ok) found a match!
[expectString] expecting accepted…(denied)LoRa init failed!
[sleep]

Ok, the day after it ‘just works again’… weird. I didn’t change a thing.
Did TTN have any problems last couple of days?