SARA R410 LTE-M no network service


We are trying to connect to the KPN LTE-M network using the following example:

KPN gave us the APN m2m.newlinemobile to use which gave the “+CME ERROR: no network service” error when using the AT command AT+CGATT=1 to attach to the network. We also tried the following APN’s (which resulted in the same error):


We have tried altering the command using the information from the unblox R410 datasheet (

We also checked if the firmware was up to date. The current version is L0.,A.02.04.
In the image provided you can see the used commands and the response.

We hope we provided you with enough information to figure out what we did wrong.

Hi @Tho.mas,

I see you set profile 1, this is auto profile selection. Maybe it doesn’t get the correct settings from the SIM.
You can try with profile 100 to set it to General Europe.

Let me know if this helps!

Best regards,

Hi Jan,

(I’m replying as @Tho.mas, because I tried uploading 2 pictures in one post and this apparently is not allowed and instantly places the account on Hold…)

Thanks for responding.

We’ve tried setting the profile to 100. This didn’t yield any results.

However, what caught our attention was the error code we got returned by the AT+CEREG command. When comparing this response to the AT commands (& responses) from the datasheet, it looks like the format is wrong.

Where we get a ‘B’ as response, the datasheet tells us that the expected value on that position should be a number. As you can see in the previous post, we got almost the same response. So, our troubleshooting has somewhat grinded to a halt.

Also, when entering the ‘AT+COPS=1,2,“20408”’ (forcing KPN) we get the response ‘+CME ERROR: no network service’, although this command was working properly before. This EVEN happened when I backtracked my own steps and executed the exact same commands as the post before.

I’m desperate to solving this issue. Can you please help me.

Thank you in advance.

I didn’t get a notification about this :cry: I did re-activate his account.
Please send a mail to if this happens again!

After changing settings, did you send the command AT+CFUN=15 to save the settings and reboot?

Best regards,

Added images for troubleshooting.

Hoi Bob,

Profile is allowed to be 100 for KPN.
Profile 1 is use settings from the SIM card, so the profile will update to another provider if listed.
Profile 100 can be used also for KPN.

Can you check at your SIM card provider that the SIM is activated for LTE-M ?
Note: LTE(4G) is not the same as LTE-M

Best regards,