R412M board fails to connect

Hi,

I have two Sodaq Sara boards on my desk, a R410M and a R412M. They both have UK Vodafone NBIOT trial SIMs installed. The R410M boards works as expected and connects to the Vodafone DBIOT network OK. However the R412M board fails to connect (it times-out at the AT+COPS=1,2,“23415” command to lock to Vodafone. I tried swapping the SIMs and the problem stayed on the R412M board. I also tried swapping the antennas which made no difference either

Below is the output from the SARA-R4_Maker in CMD mode using the following set of AT commands
ATE0
AT+CGMI
AT+CGMM
AT+CGMR
AT+URAT=8
AT+CFUN=0
AT+CGDCONT=1,“IP”,“eplpwa.vodafone.iot”
AT+CFUN=1
AT+COPS=1,2,“23415” <----- This is where the R412 board fails
AT+CSQ
AT+CFUN=15
AT+CSQ

=== This is the results from the R410M board that works OK ====

10:37:48.701 -> ATE0
10:37:48.701 -> >> ATE0
10:37:48.701 -> [rdResp]: ATE0
10:37:48.701 -> [rdResp]: OK

10:37:54.079 -> AT+CGMI
10:37:54.079 -> >> AT+CGMI
10:37:54.079 -> [rdResp]: u-blox
10:37:54.116 -> [rdResp]: OK

10:37:59.261 -> AT+CGMM
10:37:59.261 -> >> AT+CGMM
10:37:59.261 -> [rdResp]: SARA-R410M-02B
10:37:59.306 -> [rdResp]: OK

10:38:04.556 -> AT+CGMR
10:38:04.556 -> >> AT+CGMR
10:38:04.556 -> [rdResp]: L0.0.00.00.05.06 [Feb 03 2018 13:00:41]
10:38:04.556 -> [rdResp]: OK

10:38:10.416 -> AT+URAT=8
10:38:10.416 -> >> AT+URAT=8
10:38:10.416 -> [rdResp]: OK

10:38:17.224 -> AT+CFUN=0
10:38:17.224 -> >> AT+CFUN=0
10:38:17.224 -> [rdResp]: OK

10:38:23.846 -> AT+CGDCONT=1,“IP”,“eplpwa.vodafone.iot”
10:38:23.846 -> >> AT+CGDCONT=1,“IP”,“eplpwa.vodafone.iot”
10:38:23.846 -> [rdResp]: OK

10:38:29.901 -> AT+CFUN=1
10:38:29.901 -> >> AT+CFUN=1
10:38:29.901 -> [rdResp]: OK

10:38:35.406 -> AT+COPS=1,2,“23415”
10:38:35.406 -> Initializing module, this may take 3 minutes…
10:38:35.406 -> >> AT+COPS=1,2,“23415”
10:38:35.406 -> [rdResp]: OK

10:38:41.365 -> AT+CSQ
10:38:41.365 -> >> AT+CSQ
10:38:41.365 -> [rdResp]: +CSQ: 6,99
10:38:41.401 -> [rdResp]: OK

10:38:46.436 -> AT+CFUN=15
10:38:46.436 -> >> AT+CFUN=15
10:38:46.436 -> [rdResp]: OK

10:38:59.670 -> AT+CSQ
10:38:59.670 -> >> AT+CSQ
10:38:59.670 -> [rdResp]: +CSQ: 7,99
10:38:59.715 -> [rdResp]: OK

And this is the result from the R412M board that fails at the +COPS command

10:42:25.964 -> ATE0
10:42:25.964 -> >> ATE0
10:42:25.964 -> [rdResp]: ATE0
10:42:26.004 -> [rdResp]: OK

10:42:31.324 -> AT+CGMI
10:42:31.324 -> >> AT+CGMI
10:42:31.324 -> [rdResp]: u-blox
10:42:31.364 -> [rdResp]: OK

10:42:36.954 -> AT+CGMM
10:42:36.954 -> >> AT+CGMM
10:42:36.954 -> [rdResp]: SARA-R412M-02B
10:42:36.994 -> [rdResp]: OK

10:42:43.084 -> AT+CGMR
10:42:43.084 -> >> AT+CGMR
10:42:43.084 -> [rdResp]: M0.09.00 [Jan 31 2019 18:59:31]
10:42:43.084 -> [rdResp]: OK

10:42:49.444 -> AT+URAT=8
10:42:49.444 -> >> AT+URAT=8
10:42:49.444 -> [rdResp]: AT+URAT=8
10:42:49.444 -> [rdResp]: OK

10:42:55.224 -> AT+CFUN=0
10:42:55.224 -> >> AT+CFUN=0
10:42:55.224 -> [rdResp]: AT+CFUN=0
10:42:55.264 -> [rdResp]: OK

10:43:00.714 -> AT+CGDCONT=1,“IP”,“eplpwa.vodafone.iot”
10:43:00.754 -> >> AT+CGDCONT=1,“IP”,“eplpwa.vodafone.iot”
10:43:00.754 -> [rdResp]: AT+CGDCONT=1,“IP”,“eplpwa.vodafone.iot”
10:43:00.754 -> [rdResp]: OK

10:43:08.044 -> AT+CFUN=1
10:43:08.044 -> >> AT+CFUN=1
10:43:08.044 -> [rdResp]: AT+CFUN=1
10:43:08.044 -> [rdResp]: OK

10:43:15.454 -> AT+COPS=1,2,“23415”
10:43:15.454 -> Initializing module, this may take 3 minutes…
10:43:15.454 -> >> AT+COPS=1,2,“23415”
10:43:15.454 -> [rdResp]: AT+COPS=1,2,“23415”
10:46:15.524 -> [rdResp]: timed out

I then tried various combinations of commands, sometimes it is able to list the available networks (including the one I’m trying to connect to), at other times this command fails too:

10:47:13.862 -> AT+CSQ
10:47:13.862 -> >> AT+CSQ
10:47:13.862 -> [rdResp]: AT+CSQ
10:47:13.862 -> [rdResp]: +CSQ: 99,99
10:47:13.862 -> [rdResp]: OK

10:47:22.597 -> AT+CFUN=15
10:47:22.597 -> >> AT+CFUN=15
10:47:22.597 -> [rdResp]: AT+CFUN=15
10:47:22.597 -> [rdResp]: OK

10:47:35.057 -> AT+CSQ
10:47:35.057 -> >> AT+CSQ
10:47:35.057 -> [rdResp]: AT+CSQ
10:47:35.057 -> [rdResp]: +CSQ: 99,99
10:47:35.102 -> [rdResp]: OK

10:47:42.022 -> AT+COPS=1,2,“23415”
10:47:42.022 -> Initializing module, this may take 3 minutes…
10:47:42.022 -> >> AT+COPS=1,2,“23415”
10:47:42.022 -> [rdResp]: AT+COPS=1,2,“23415”
10:50:42.037 -> [rdResp]: timed out

10:53:22.940 -> AT+COPS=?
10:53:22.940 -> Initializing module, this may take 3 minutes…
10:53:22.940 -> >> AT+COPS=?
10:53:22.940 -> [rdResp]: AT+COPS=?
10:53:46.040 -> [rdResp]: +COPS: (1,“234 15”,“234 15”,“23415”,9),(0,1,2,3,4),(0,1,2)
10:53:46.080 -> [rdResp]: OK

10:54:12.240 -> AT+COPS=?
10:54:12.240 -> Initializing module, this may take 3 minutes…
10:54:12.240 -> >> AT+COPS=?
10:54:12.240 -> [rdResp]: AT+COPS=?
10:54:12.479 -> [rdResp]: +CME ERROR: operation not allowed

10:54:16.000 -> AT+COPS=?
10:54:16.000 -> Initializing module, this may take 3 minutes…
10:54:16.000 -> >> AT+COPS=?
10:54:16.000 -> [rdResp]: AT+COPS=?
10:54:16.319 -> [rdResp]: +CME ERROR: operation not allowed

10:54:17.765 -> AT+COPS=?
10:54:17.765 -> Initializing module, this may take 3 minutes…
10:54:17.765 -> >> AT+COPS=?
10:54:17.765 -> [rdResp]: AT+COPS=?
10:54:18.080 -> [rdResp]: +CME ERROR: operation not allowed

10:54:28.914 -> AT+CFUN=15
10:54:28.914 -> >> AT+CFUN=15
10:54:28.914 -> [rdResp]: AT+CFUN=15
10:54:28.914 -> [rdResp]: OK

10:54:36.419 -> AT+COPS=?
10:54:36.419 -> Initializing module, this may take 3 minutes…
10:54:36.419 -> >> AT+COPS=?
10:54:36.419 -> [rdResp]: AT+COPS=?
10:54:58.010 -> [rdResp]: +CME ERROR: operation not allowed

10:55:06.039 -> AT+COPS=?
10:55:06.039 -> Initializing module, this may take 3 minutes…
10:55:06.039 -> >> AT+COPS=?
10:55:06.039 -> [rdResp]: AT+COPS=?
10:55:06.359 -> [rdResp]: +CME ERROR: operation not allowed

10:55:25.059 -> AT+COPS=1,2,“23415”
10:55:25.059 -> Initializing module, this may take 3 minutes…
10:55:25.059 -> >> AT+COPS=1,2,“23415”
10:55:25.059 -> [rdResp]: AT+COPS=1,2,“23415”
10:58:25.118 -> [rdResp]: timed out

11:05:13.816 -> AT+COPS=?
11:05:13.816 -> Initializing module, this may take 3 minutes…
11:05:13.816 -> >> AT+COPS=?
11:05:13.816 -> [rdResp]: OK

11:10:11.159 -> AT+COPS=?
11:10:11.159 -> Initializing module, this may take 3 minutes…
11:10:11.159 -> >> AT+COPS=?
11:10:11.159 -> [rdResp]: timed out

Can anyone shed any light? Is there a command to reset the board to factory settings (ie clear the NVM). Do I have a faulty board?
Many thanks,
Julian.

Hi @JulianDaley,

Did you connect a battery to your R412?
The R410 connects without having a battery connected, the R412 will not.

Best regards,
Jan

Well, that was easy! It works now. Many thanks.
Julian.

1 Like