Connecting from Ireland

Hi There,

I’m a new developer, looking to connect the NB-IoT shield using vodafone’s NB-IoT network in Ireland.

Using the example code from github, how would you suggest id edit the following line:
if (nbiot.connect(“oceanconnect.t-mobile.nl”, “172.16.14.22”, “20416”)

Is this example is using huawei oceanconnect cloud platform? How would I edit for an alternative cloud platform such as thething.io

Kind Regards,

TJ

How can I find out the correct provider ID for vodafone in Ireland in order to connect my SODAQ NB-IoT shield?

TJ

I would say, get in contact with your local service provider: http://www.vodafone.com/business/iot/nb-IoT, http://www.vodafone.ie/small-business/smart-solutions/machine-to-machine/

2 Likes

Did you get an answer ?

The operator ID is a combination of mobile country code (MCC) and mobile network code (MNC). So, the operator id format (MCC/MNC) for Vodafone Eircell is 27201.

In the command line example you showed, operator ID is for T-Mobile NL (MCC: 204 and MNC:16) which will make the operator id code: 20416.

Please feel free to check your serving operator MCC/MNC in the below link.

http://www.mcc-mnc.com

The “oceanconnect.t-mobile.nl” is the APN (Access Point Name) for NB-IoT in T-Mobile NL service. If you are not using T-Mobile NL SIM card, then you probably need to check what the APN used for NB-IoT service in your serving operator.
The “172.16.14.22” is the CDP IP which is connected device platform IP which also belong to T-Mobile NL core network element.

1 Like

Hi,
Did anyone manage to connect to Vodafone Ireland NB-IoT? I have a Sodaq Sara R412M in Cork and would love sample code to connect to Vodafone Ireland or vodafone.allthingstalk.io. My ‘V by Vodafone’ app is showing that my NB-IoT vsim is connected.

These are the settings that I tried but must be incorrect:
const char* apn = “vodafone.allthingstalk.io”;
const char* cdp = “40.68.172.187”;
const char* forceOperator = “27201”; // vodafone eircell Ireland

As this fails to connect:
if (nbiot.connect(apn, cdp, forceOperator)) {
DEBUG_STREAM.println(“Connected succesfully!”);
}

Or, has anyone a contact for NB-IoT support in Vodafone Ireland?

Thanks,
Lisa.

Hi @lisa,

Should be not not used in code. This is for COAP, the sending to AllThingsTalk is with UDP.

The correct APN: nb.inetd.gdsp
See also https://vodafoneiot.sodaq.com/quick-start/next-steps/

You can force the operator, or use “0” to use automatic.

Hope this helps!

Best regards,
Jan

Thank you Jan for your quick response. I tried the code you recommended in https://vodafoneiot.sodaq.com/quick-start/next-steps/ and entered the AT commands in the serial monitor but the command AT+COPS=1,2,“27201” hung so I tried AT+COPS=0 as you advised in:
NB-IOT in Germany with Vodafone SIM
I could proceed further until I got to command: AT+USOCR=17 Response:
+CME ERROR: No connection to phone
+CEREG: 2
+CEREG: 0

If you have any advice on how to troubleshoot this, or if you have any other useful tutorials for complete beginners I would be very grateful. It would be super to be able to get a message out and start the fun stuff. :slight_smile:

Regards,
Lisa.

Other code:

AT+URAT=8
OK
AT+URAT?
+URAT: 8
OK
AT+CMEE=2
OK
AT+CGDCONT=1,“IP”,“nb.inetd.gdsp”
OK
AT+CGDCONT?
+CGDCONT: 1,“IP”,“nb.inetd.gdsp”,“0.0.0.0”,0,0,0,0
OK
AT+CFUN=1
OK
AT+COPS=1,2,“27201”
(hang)

It’s correct this command ‘hangs’ you force it to connect to this operator. It will timeout after 5 minutes.
So you have to be a little patience.

With AT+COPS=0 you will get a reply immediately but you are not connected.
You have to send AT+CSQ till you have a valid CSQ (no 99,99 but something,99)
And the AT+CGATT till you are attached, return 1.

Can you send me the firmware version of your module?
The command is “ATI9”

Best regards,
Jan

Thanks again Jan. When I wait for connection I get this error:
AT+CFUN=1
OK
AT+COPS=1,2,“27201”
+CME ERROR: no network service

When I send ATI9 my firmware version returns as:
M0.09.00,A.02.11
I see on your website that the latest firmware version for the R412 is M0.10.00,A.02.14

If someone can direct me to a download and instructions I will upgrade my firmware.

Regarding the network service error, would you recommend that I contact Vodafone Ireland? I have tried in the past and it is hard to find anyone who knows about NB-IoT. I have been told that NB-IoT is available in my area.

Thanks,
Lisa.

I am now getting a signal value between 6 and 9 but getting a connection error. Is the signal too poor or should I check something else?
AT+USOCR=17
+CME ERROR: No connection to phone

Before the error above, this is the feedback :
AT+CGDCONT?
+CGDCONT: 1,“IP”,“nb.inetd.gdsp”,“0.0.0.0”,0,0,0,0
OK
AT+CFUN?
+CFUN: 1
OK
AT+COPS?
+COPS: 0,0,“272 01 CIOT Vodafone”,3
OK
AT+CSQ
+CSQ: 9,99
OK

Hi Lisa,

The signal is very poor, but you should be able to connect.
When you have a signal you are not automatically connected. Since you have poor signal getting connected can take some time.

You can send the command AT+CGATT? when it returns 1 you are connected.
You will be able to send data when you have a valid IP address, this can be checked with AT+CGDCONT?

The first check you do with AT+CGDCONT? in your AT sequence is to check the APN.
After you are connected you can use the same command to check the IP address.

Have a bit patience, it can take up to 3 minutes per band to scan and get connected.
With AT+UBANDMASK? you can see the used bandmask.
AT+UBANDMASK=“524288”

Hope this helps you get connected.

Best regards,
Jan

It’s recommended to update the firmware, can you send an email to us?
Then we can link the firmware files.

Best regards,
Jan

Has anyone in Ireland connected to Vodafone Narrowband using Sodaq R412M successfully?
I’d love to know the APN and settings used.