Can't connect to network in Sodaq R4X example Sketch

Hello. I’m trying to use your HTTP Test example, found here https://github.com/SodaqMoja/Sodaq_R4X

Since I’m in Portugal, I had to use the following settings

define CURRENT_APN “internetm2m”
define CURRENT_OPERATOR “26806”
define CURRENT_URAT SODAQ_R4X_LTEM_URAT
define CURRENT_MNO_PROFILE MNOProfiles::SIM_ICCID

The Operator I’m using is MEO (or Altice), but I always get a Network Connection Failed. Should I change any other Setting?

Hi @nunof,

Did you update the R4X module to the latest firmware version?
https://support.sodaq.com/Boards/Sara_AFF/#r4

You can force the operator or use 0 for automatic.

Can you in the enable the debug information?
Uncomment //#define DEBUG in Sodaq_R4X.cpp

Please share the output.

Best regards,
Jan

The firmware version I’m using is older than the current one, I have L0.0.00.00.05.06,A.02.00

Uncommening the debug it gives me CME error, with no network service.

So the suggested next step is to upgrade the firmware I suppose?

Hi @nunof,

Version 1.0.0 of the library will work for you.
Version 2.0.0 and up require the latest ublox firmware.
The ublox firmware isn’t backward compatible. For stability I recommend to update to the latest firmware.

Best regards,
Jan

Thank you for your help, now with the older library, I get stuck with the >> AT+CGATT? << +CGATT: 0 command, it seems it cannot attach the GPRS. Any suggestions?

Are you sure you have LTE-M network coverage?
LTE-M is not the same as 4G/LTE.

Portugal only has nb-IOT coverage as seen here https://www.gsma.com/iot/deployment-map/#PT

Does that mean I can’t connect?

You try to connect to the LTE-M network.

If your simcard can be connected to the NB-IoT network, you need to change this parameter and run the example again.